Loading

連接到 Excel 檔案時出現錯誤:載入資料來源時發生錯誤。

發佈日期: Jul 27, 2023
描述
連接到 Excel 檔案時,Tableau Desktop 中可能會出現以下錯誤:

「加載資料來源時出錯。」



與資料來源「<資料來源名稱>」通訊時出錯。
加載資料來源時出錯。
Unable to connect to the server.(無法連線到伺服器。)請檢查伺服器是否正在執行中,並且您具有所請求資料庫的存取權限。

Cause

此錯誤可能有多種原因,包括:
  • Excel 檔案損壞
  • Excel 檔案路徑已變更
  • Excel 檔案正在使用以 .xls 結尾的舊版本檔案
解決方案

選項 1 - 可能損壞的檔案

  1. 開啟受影響的 Excel 檔案。
  2. 複製檔案中的全部資料。
  3. 將資料貼上到一個新 Excel 檔案中。
  4. 保存這個新 Excel 檔案。
  5. 將 Tableau Desktop 連接到這個新 Excel 檔案。

選項 2 - 檔案路徑已變更?

在 Tableau Desktop 中:
  1. 打開 Tableau Desktop 工作簿。
  2. 在視窗左上方的「資料」窗格中右鍵按一下資料來源,然後選擇「編輯資料來源...」
  3. 按一下 Excel 檔案名稱,並確認連線指向正確的檔案路徑。 您可在「連線」>「<資料來源> 下拉式功能表」>「編輯連線...」中找到此選項
  4. 如果檔案路徑錯誤,則重新建立到位於正確檔案路徑的 Excel 檔案的連接。
對於 Tableau Server/Cloud
了解資料是否單獨發布或是何時嵌入到已發布的工作簿中非常重要。

如果資料是單獨發布的,您可以使用本知識庫文章編輯已發布的資料來源中概述的「本機副本」方法來確定檔案的路徑並進行所需的任何調整,然後重新發布資料來源。 

如果資料嵌入到工作簿中,請從 Tableau Server 或 Tableau Cloud 下載工作簿並執行選項 2 中的步驟並重新發布工作簿。

選項 3 - 舊檔案類型

如果使用在早期版本的 Microsoft Excel 中建立的檔案,我們需要將檔案副檔名從 .xls 變更為 .xlsx。 
  1. 在 Microsoft Excel 中打開 Excel 檔案,然後用 .xlsx 擴展名保存該檔案。 
  2. 打開 Tableau Desktop、Tableau Server 或 Tableau Cloud 並重新連接到 .xlsx 檔案。 
知識文章編號

001472091

 
正在載入
Salesforce Help | Article