Loading

Code d'erreur C926DA9F « An error occurred when publishing the workbook » (Une erreur s'est produite lors de la publication du classeur) lors de la publication

Date de publication: Apr 5, 2024
Description
Lorsque vous tentez de publier un contenu depuis Tableau Desktop sur Tableau Server, l'une des erreurs suivantes se produit :

Une erreur s'est produite lors de la publication du classeur
Error Code: C926DA9F (Code d'erreur : C926DA9F)
Vous ne disposez pas des droits nécessaires pour effectuer l'opération requise.

OR

Une erreur s'est produite lors de la publication du classeur
Error Code: C926DA9F (Code d'erreur : C926DA9F)
L'objet spécifié n'existe pas.

OR

Une erreur s'est produite lors de la publication du classeur
Error Code: C926DA9F (Code d'erreur : C926DA9F)
"An unknown error related to remote content was detected (500)." (Une erreur inconnue liée au contenu distant a été détectée (500))

Cause

Le code d'erreur C926DA9F représente une erreur qui survient lors de la publication et qui peut avoir des causes multiples, y compris un proxy qui interfère avec les communications entre Tableau Server et Tableau Desktop, des autorisations incorrectes pour le compte Exécuter en tant qu'utilisateur Tableau Server ou la publication sur une version Tableau Server restaurée depuis une version plus récente de sauvegarde (.tsbak).
 
Résolution
Suivez les étapes suivantes pour résoudre votre problème : 
  1. Veuillez vérifier que ///Run as User account/// sur Tableau Server respecte les autorisations du répertoire, les autorisations du registre et lespolitiques de sécurité locales.  Consultez Paramètres requis du compte Exécuter en tant que serveur.

  2. Si un proxy est utilisé, adressez-vous à votre équipe informatique locale pour ajouter une exception dans le proxy pour Tableau Desktop. Tableau Desktop pourra ainsi joindre le serveur afin de publier.

  3. Si un proxy inverse a récemment été ajouté, assurez-vous que Tableau Server est correctement configuré pour lui. Pour plus d'informations, consultez Configuration des proxy pour Tableau Server.

  4. Vérifiez que la fonctionnalité Visibilité des utilisateurs n'est pas définie sur Limité. Lorsqu'elle est définie sur Limité, les utilisateurs dotés du rôle ExplorerCanPublish ne sont pas en mesure de publier sur Tableau Server. Consultez Gérer la visibilité des utilisateurs du site.

  5. Assurez-vous que Tableau Server est restauré avec la même version ou une version plus ancienne de la sauvegarde (.tsbak). Les sauvegardes Tableau Server prennent en charge la compatibilité ascendante (utilisation d'une ancienne version de .tsbak pour effectuer une restauration à partir d'une version plus récente de Tableau Server). Cependant, la rétrocompatibilité (utilisation d'une version plus récente de .tsbak pour restaurer une ancienne version de Tableau Server) n'est pas prise en charge actuellement. Pour plus d'informations, consultez Retour à une installation précédente de Tableau Server.

  6. Exécutez la commande tsm maintenance reset-searchserver. Ce problème se produit également lorsqu’il existe un problème dans l’index généré par le processus du serveur de recherche. Réinitialisez l’index et essayez de republier. Consultez Recherche et navigation sur Tableau Server.

Numéro d’article de la base de connaissances

001472189

 
Chargement
Salesforce Help | Article