Loading

Codice errore C926DA9F "An error occurred when publishing the workbook" durante la pubblicazione

Data pubblicazione: Apr 5, 2024
Descrizione
Quando si tenta di pubblicare contenuto da Tableau Desktop a Tableau Server, si verifica uno dei seguenti errori:

An error occurred when publishing the workbook (Si è verificato un errore durante la pubblicazione della cartella di lavoro)
Error Code: C926DA9F
L'operazione richiesta non può essere eseguita perché non disponi della necessaria autorizzazione.

OPPURE

An error occurred when publishing the workbook (Si è verificato un errore durante la pubblicazione della cartella di lavoro)
Error Code: C926DA9F
L'oggetto specificato non esiste.

OPPURE

An error occurred when publishing the workbook (Si è verificato un errore durante la pubblicazione della cartella di lavoro)
Error Code: C926DA9F
È stato rilevato un errore sconosciuto relativo al contenuto remoto (500)

Cause

Il codice di errore C926DA9F rappresenta un errore durante la pubblicazione e può avere più cause, tra cui un proxy che interferisce con le comunicazioni tra Tableau Server e Tableau Desktop, autorizzazioni non corrette per l'opzione Esegui come utente di Tableau Server o la pubblicazione in un Tableau Server ripristinato con una versione più recente del backup (.tsbak).
 
Risoluzione
Per risolvere il problema, segui i seguenti passaggi di risoluzione:
  1. Verifica che l'account Esegui come utente su Tableau Server soddisfi le Autorizzazioni delle cartelle, le Autorizzazioni del registro e i Criteri di sicurezza locali.  Vedi Impostazioni richieste dell'account di servizio Esegui come.

  2. Se è in uso un proxy, collabora con il team IT locale per aggiungere un'eccezione nel proxy per Tableau Desktop. Ciò consentirà a Tableau Desktop di raggiungere il server per eseguire la pubblicazione.

  3. Se di recente è stato aggiunto un proxy inverso, verifica che Tableau Server sia configurato correttamente per tale proxy. Per maggiori informazioni, consulta Configurare i proxy per Tableau Server.

  4. Verifica che la funzionalità Visibilità utente non sia impostata su Limitata. Quando la funzionalità è impostata su Limitata, gli utenti ExplorerCanPublish non saranno in grado di eseguire la pubblicazione in Tableau Server. Consulta Gestire la visibilità degli utenti del sito.

  5. Assicurati che Tableau Server sia ripristinato con la stessa versione del backup (.tsbak) o con una versione precedente. I backup di Tableau Server supportano la compatibilità in avanti (ossia l'uso di una versione precedente di .tsbak per ripristinare Tableau Server a una versione più recente). Tuttavia, la retrocompatibilità (ossia l'uso di una versione più recente di .tsbak per ripristinare Tableau Server a una versione precedente) non è attualmente supportata. Per maggiori informazioni, consulta Ripristino di un'installazione precedente di Tableau Server.

  6. Esegui il comando tsm maintenance reset-searchserver. Questa situazione si verifica anche quando c'è un problema con l'indice generato dal processo searcheserver, pertanto reimposta l'indice e prova a eseguire nuovamente la pubblicazione. Consulta Ricerca e Sfoglia di Tableau Server.

Numero articolo Knowledge

001472189

 
Caricamento
Salesforce Help | Article