Loading

Impossible d'installer, de mettre à niveau ou de redémarrer Tableau Server

Date de publication: Feb 20, 2023
Description
Après un redémarrage de Tableau Server, ou lors de l'installation/de la mise à niveau, Tableau Server ne peut pas démarrer et tsm status -v affiche tous les services soit comme non disponibles, soit dans un état d'erreur.

Cause

Le code d'erreur Windows [-1073741515] n'est pas un code d'erreur Tableau Server. Il indique généralement soit des fichiers DLL manquants (pertinent pour des problèmes d'installation/de mise à niveau en particulier), soit des problèmes avec des autorisations/une stratégie de groupe.
Résolution
Pour résoudre ce problème, vérifiez que les autorisations nécessaires sont appliquées au compte Exécuter en tant que service (RAS) pour Tableau Server et qu'aucune stratégie de groupe n'écrase les autorisations locales.

Une solution potentielle consiste à modifier le compte RAS ou à réappliquer les autorisations pour ce compte.
Ressources supplémentaires
Pour identifier rapidement ce problème, recherchez ce qui suit dans le journal tabsvc_nodeX-0.log sur un nœud affecté :
 
        exited with code [-1073741515]

Exemples :
 
2020-01-20 19:00:29.316 -0500  Thread-5426 : INFO  com.tableausoftware.process.win32.Win32SystemProcess - Process [1708] exited with code [-1073741515].
2020-01-20 19:00:29.316 -0500  Thread-5426 : ERROR com.tableausoftware.tabsvc.TabSvcProcessManager - Service vizportal_0 with PID 1708 terminated with exit code -1073741515

2020-01-20 19:05:16.604 -0500  Thread-5429 : INFO  com.tableausoftware.process.win32.Win32SystemProcess - Process [6644] exited with code [-1073741515].
2020-01-20 19:05:16.604 -0500  Thread-5429 : ERROR com.tableausoftware.tabsvc.TabSvcProcessManager - Service apigateway_0 with PID 6644 terminated with exit code -1073741515
 
Assurez-vous qu'aucun des articles suivants ne s'applique en vérifiant les DLL pertinentes :
 
Numéro d’article de la base de connaissances

001472230

 
Chargement
Salesforce Help | Article