Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

Hyper インストールのリセット時の不明なサーバー エラー "hyper Api: Could Not Connect To The Hyper Server" (hyper Api: Hyper サーバーに接続できませんでした)

公開日: Dec 9, 2022
説明

Hyper のインストールをリセットした後、Tableau Server 上のパブリッシュされたワークブックにアクセスしようとすると、次のエラーが発生します。

 "Unknown Server Error" (不明なサーバー エラー) "Hyper API: Could not connect to the Hyper server" (Hyper API: Hyper サーバーに接続できませんでした)

Cause

Tableau Server と Hyper の併用時、ポートの再インストールまたは変更の間にポートは動的に割り当てられます。再インストール後、トポロジでもポートを設定する必要があります。
解決策
1. ポート 8000 ~ 9000 のうち、Tableau Server でブロックされているポートがないことを確認します。
2. Hyper を再インストールする必要があるか、また、TSM 上のポートに一致するようポートを再設定する必要があるか確認します。
3. 要求されているポートがリッスンしている場合、netstat を取得してそのポートのエラーを確認します。
4. Tableau Server によって指定されているポートと Hyper が要求しているポートが異なっている場合、前者が何番のポートであるかを Tableau Server の構成で確認します。
5. 要求されたポートの新しい構成を更新して、新しいインストールと一致させます。

tsm topology list-nodes (変更するノード名を確認)
tsm topology set-ports --node-name <ノード> --port-name hyper--port-value <ポート番号>
tsm pending-changes apply
 
その他のリソース
Tableau Server の特定部分の再インストールでユーザーが構成をリセットしない場合、ポートを再インストールまたはポート設定を変更すると Tableau Server でこの問題が発生する可能性があります。
ナレッジ記事番号

001472410

 
読み込み中
Salesforce Help | Article