Loading

Fehler "Anmeldung nicht möglich", "Ein Benutzer mit demselben Benutzernamen existiert bereits in Tableau Server." erscheint beim Verwenden von OpenID zum Anmelden.

Veröffentlichungsdatum: Dec 9, 2022
Beschreibung

Bei der Verwendung von OpenID Connect schlägt die Anmeldung nach dem Löschen und Hinzufügen eines Benutzers mit demselben Benutzernamen in Tableau Server mit der folgenden Fehlermeldung fehl:

"Unable to sign in" (Anmeldung nicht möglich), "A user with the same user name already exists on Tableau Server." (Ein Benutzer mit demselben Benutzernamen existiert bereits in Tableau Server.)

Cause

Der Unterwert ist eine eindeutige Zeichenfolge, die ein bestimmtes Benutzerkonto identifiziert. Sie ändert sich auch dann nicht, wenn der Administrator die mit diesem Konto verbundenen Benutzer- oder IdP-Angaben (E-Mail, Telefonnummer usw.) bearbeitet, löscht und neu erstellt. 
 
Lösung
1. Prüfen Sie, ob der Benutzer, der den Fehler verursacht hat, gelöscht und mit derselben Benutzer-ID / demselben Benutzernamen neu angelegt wurde.
2. Wenn ja, verwenden Sie den Befehl tabcmd reset_openid_sub, um Unterwerte für Benutzer zu löschen.

Weitere Informationen finden Sie unter Ändern von IdPs in Tableau Server für OpenID Connect.
Zusätzliche Ressourcen
  • Normalerweise wird die OpenID-Bereitstellungssequenz die Unterzuordnung im IdP beanspruchen. Weitere Informationen finden Sie unter IdP-Angaben: Zuordnung von Benutzern.
  • Der Befehl tabcmd reset_openid_sub wird in Tableau Server 2019.4 oder höher angegeben. 
Nummer des Knowledge-Artikels

001472420

 
Laden
Salesforce Help | Article