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Error "Unable to sign in" (No se puede iniciar sesión), "A user with the same user name already exists on Tableau Server" (Ya existe un usuario con el mismo nombre en Tableau Server) al usar OpenID para iniciar sesión.

Fecha de publicación: Dec 9, 2022
Descripción

Al usar OpenID Connect, después de eliminar y agregar un usuario con el mismo nombre de usuario en Tableau Server, se produce el siguiente error en el inicio de sesión:

"Unable to sign in (No se puede iniciar sesión)", "A user with the same user name already exists on Tableau Server (Ya existe un usuario con el mismo nombre de usuario en Tableau Server)".

Cause

El subvalor es una cadena única que identifica la cuenta de un determinado usuario. No se modifica, ni siquiera si el administrador edita, elimina o vuelve a crear el usuario o las declaraciones de IdP (correo electrónico, número de teléfono, etc.) asociados a esa cuenta. 
 
Solución
1. Compruebe si se borró el usuario que originó el error y se volvió a crear con el mismo ID o nombre de usuario.
2. De ser así, utilice el comando tabcmd reset_openid_sub para borrar los subvalores de los usuarios.

Para obtener más información, consulte Cambiar los IdP en Tableau Server para OpenID Connect.
Recursos adicionales
  • Por lo general, la secuencia de aprovisionamiento de OpenID notificará la subasignación en el IdP. Si desea obtener más información, consulte Declaraciones de IdP: asignación a usuarios.
  • Se proporciona el comando tabcmd reset_openid_sub en Tableau Server 2019.4 o versiones posteriores. 
Número del artículo de conocimiento

001472420

 
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