Loading

エラー "unable To Sign In"、"a User With The Same User Name Already Exists On Tableau Server." (サインインできません)、(同じ名前のユーザーが既に Tableau Server 上に存在しています。) OpenID を使用したログイン時に発生

公開日: Dec 9, 2022
説明

OpenID Connect の使用時に、Tableau Server でユーザーを削除して同じユーザー名でユーザーを追加した後、次のエラーでログインが失敗します。

"Unable to sign in"、"A user with the same user name already exists on Tableau Server." (サインインできません)、(同じ名前のユーザーが既に Tableau Server 上に存在しています。)

Cause

サブ値は、特定のユーザーアカウントを識別する一意の文字列です。そのアカウントに関連付けられているユーザー クレームまたは IdP クレーム (メール、電話番号など) を管理者が編集したり、削除して作成し直したりしても、サブ値は変化しません。 
 
解決策
1. エラーの原因になったユーザーが削除され、同じユーザー ID/名前で作成し直されているかどうかを確認します。
2. その場合、tabcmd reset_openid_sub コマンドを使用してユーザーのサブ値をクリアします。

詳細については、「Tableau Server で OpenID Connect 用に IdP を変更する」を参照してください。
その他のリソース
  • 通常、OpenID のプロビジョニング シーケンスでは、IdP でのサブマッピングが要求されます。詳細については、「IdP クレーム: ユーザーのマッピング」を参照してください。
  • tabcmd reset_openid_sub コマンドは、Tableau Server 2019.4 以降で提供されています。 
ナレッジ記事番号

001472420

 
読み込み中
Salesforce Help | Article