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Error "unable To Sign In", "a User With The Same User Name Already Exists On Tableau Server." Occurs When Using Openid To Login

Дата публикации: Feb 23, 2026
Описание

When using OpenID Connect, after deleting > adding a user with the same username in Tableau Server, login fails with the error:

"Unable to sign in", "A user with the same user name already exists on Tableau Server."

Cause

The sub value is a unique string that identifies a given user account. It will not change even if admin edits user or IdP claims (email, phone number, etc) associated with that account, delete and recreate them. 
 
Решение
1. Check if the user causing the error has been deleted and recreated with the same userid/name.
2. If so, use the tabcmd reset_openid_sub command to clear sub values for users.

For more information see Changing IdPs in Tableau Server for OpenID Connect.
Дополнительные ресурсы
  • Typically, the OpenID provisioning sequence will claim the sub mapping in the IdP. For more information see IdP claims: mapping users.
  • The tabcmd reset_openid_sub command is provided in Tableau Server 2019.4 or later. 
Номер статьи базы знаний

001472420

 
Загрузка
Salesforce Help | Article