Loading

Die Fehler „No Tableau Server user found“ (Kein Tableau Server-Benutzer gefunden) und „DataServiceFailure“ treten gelegentlich in einer Umgebung mit mehreren Netzwerkschnittstellen (NICs) auf.

Veröffentlichungsdatum: Dec 9, 2022
Beschreibung

Beim Zugriff auf Ansichten tritt gelegentlich der folgende Fehler auf oder einige Teile der Ansicht werden nicht korrekt und vollständig dargestellt. 
Dieses Problem tritt in Umgebungen mit mehreren Netzwerkkarten (NICs) auf.
Durch mehrmaliges Klicken/Tippen auf die Schaltfläche „Erneut versuchen“ oder die Schaltfläche „Aktualisieren“ des Webbrowsers wird die Ansicht korrekt wiedergegeben. 

No Tableau Server user found (Kein Tableau Server-Benutzer gefunden)
DataServiceFailure

Vom Benutzer hinzugefügtes Bild

Cause

Wenn der Rechner mit mehreren Netzwerkkarten konfiguriert ist, arbeitet Tableau Server unter Umständen aufgrund von Netzwerkproblemen ungenau oder unzuverlässig.
Lösung

1. Fügen Sie für alle Knoten die „IP-Adresse“, den „vollständig qualifizierten Domänennamen“ (FQDN) und den „Hostnamen“ aller Knoten in die Host-Datei ein.
 Das folgende Beispiel zeigt eine Umgebung mit drei Knoten.
Die Host-Datei finden Sie unter “C:\Windows\System32\drivers\etc\hosts“.

<IP-Adresse Knoten1> <FQDN Knoten1> <Hostname Knoten1>
<IP-Adresse Knoten2> <FQDN Knoten2> <Hostname Knoten2>
<IP-Adresse Knoten3> <FQDN Knoten3> <Hostname Knoten3>


Die folgenden Befehle können verwendet werden, um die benötigten Informationen zu bestätigen.

  • ipconfig – Sucht die IP-Adresse und NIC mit DNS-Suffix.
  • net config workstation – Zeigt die FQDN (vollständiger Computername) an.
  • hostname – Zeigt den Hostnamen (Computername) an.


2. Setzen Sie die NIC mit dem öffentlichen DNS-Suffix für alle Knoten auf die höchste Priorität (niedrigster Metrikwert). Detaillierte Anweisungen finden Sie unter Zuweisen von Metriken für die einzelnen Netzwerkkarten.
Der folgende Befehl kann verwendet werden, um die Priorität vor und nach der Konfiguration zu überprüfen.

  • netsh interface ipv4 show interface 


3. Starten Sie Tableau Server neu (tsm restart).

Nummer des Knowledge-Artikels

001472466

 
Laden
Salesforce Help | Article