Loading

Error de usuario de Tableau Server no encontrado y "DataServiceFailure" de forma intermitente en un entorno de varias interfaces de red (NIC)

Fecha de publicación: Dec 9, 2022
Descripción

Al acceder a las vistas, se produce el siguiente error de forma intermitente. O bien, ciertas partes de la vista no se representan de forma correcta y completa. 
Este problema se produce en entornos de interfaces de red múltiples (NIC).
La vista se representaría apropiadamente si se presionara el botón "Volver a intentar" o se presionara varias veces el botón de actualización del navegador web. 

No se encontró ningún usuario de Tableau Server
DataServiceFailure

Imagen añadida por un usuario

Cause

Cuando se configura la máquina con varias tarjetas de red, Tableau Server puede funcionar de forma imprecisa o inestable debido a problemas de red.
Solución

1. Agregue los valores "Dirección IP", "FQDN" y "Nombre de host" de todos los nodos al archivo de hosts de todos los nodos.
 A continuación, se muestra un ejemplo de un entorno de 3 nodos.
El archivo de hosts se puede encontrar en "C:\Windows\System32\drivers\etc\hosts".

<Dirección IP de nodo1> <FQDN de nodo1> <Nombre de host de nodo1>
<Dirección IP de nodo2> <FQDN de nodo2> <Nombre de host de nodo2>
<Dirección IP de nodo3> <FQDN de nodo3> <Nombre de host de nodo3>


Es posible utilizar los siguientes comandos para confirmar la información necesaria.

  • ipconfig: Buscar la dirección IP y la NIC con el sufijo DNS
  • net config workstation: Mostrar FQDN (nombre completo del equipo)
  • hostname: Mostrar el nombre de host (nombre del equipo)


2. Configure la NIC con el sufijo DNS público en la prioridad más alta (el valor de métricas más bajo) para todos los nodos. Para obtener instrucciones detalladas, consulte Asignar métricas a cada interfaz de red.
Es posible utilizar el siguiente comando para comprobar la prioridad antes y después de la configuración.

  • netsh interface ipv4 show interface 


3. Ejecute un reinicio de Tableau Server (tsm restart).

Número del artículo de conocimiento

001472466

 
Cargando
Salesforce Help | Article