Loading

Nach der Konfiguration von SAML SSO wird der Fehler "Es wurde kein IDP konfiguriert, bitte aktualisieren Sie die enthaltenen Metadaten mit mindestens einem IDP" angezeigt

Veröffentlichungsdatum: Aug 24, 2022
Beschreibung

Nach der Konfiguration von SAML konnten sich die Benutzer nicht anmelden und sahen die Meldung "Invalid username or password, Try Again" (Ungültiger Benutzername oder Kennwort, versuchen Sie es erneut).
In den Tableau Server-Protokollen (vizportal_node# oder tomcat_vizportal_node#) wurde die folgende Fehlermeldung gefunden:
"No IDP was configured, please update included metadata with at least one IDP" (Es wurde kein IDP konfiguriert, bitte aktualisieren Sie die enthaltenen Metadaten mit mindestens einem IDP.)

Cause

Das Problem wurde durch die IdP-Datei metadata.xml verursacht, die nicht richtig formatiert war.
Eines der Szenarien, wenn nicht unterstützte Zeichen (z. B. '-') enthalten sind, verhindert, dass Tableau Server die erforderlichen Informationen des IdP identifiziert.
-<EntityDescriptor xmlns="urn:oasis:names:tc:SAML:2.0:metadata" entityID="ENTITYID" ID="ID">
-<Signature xmlns="http://www.w3.org/2000/09/xmldsig#">;
-<SignedInfo>
-<Reference URI="#">
-<Transforms>
-<KeyInfo>
-<X509Data>
.
.
.
Lösung
 
Arbeiten Sie mit Ihrem IdP-Administrator zusammen, um zu überprüfen, ob die IdP-Datei metadata.xml richtig formatiert ist.
Führen Sie nach der erneuten Generierung die folgenden Schritte aus, um die erneute Konfiguration auf TSM abzuschließen:
1. Erneuter Austausch von metadata.xml zwischen Tableau Server und IdP
  • Laden Sie die Datei metadata.xml erneut von TSM herunter und laden Sie sie zum IdP hoch (Schritt 2 - Schritt 3).
  • Laden Sie die neu generierte Datei metadata.xml des IdP in TSM hoch (Schritt 4).
2. Klicken Sie auf 'Ausstehende Änderungen speichern' > Klicken Sie auf 'Ausstehende Änderungen' am Beginn der Seite > Klicken Sie auf 'Änderungen übernehmen und neu starten'.
*Durch die Anwendung ausstehender Änderungen wird Tableau Server neu gestartet. 
Nummer des Knowledge-Artikels

001472510

 
Laden
Salesforce Help | Article