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Error "No se ha configurado ningún IDP; actualice los metadatos incluidos con al menos un IDP" después de configurar el SSO de SAML

Fecha de publicación: Aug 24, 2022
Descripción

Después de configurar SAML, se produjo un error cuando los usuarios intentaron iniciar sesión: "El nombre de usuario o la contraseña son incorrectos, vuelva a intentarlo"
En los registros de Tableau Server (vizportal_node# o tomcat_vizportal_node#) se encontró el siguiente mensaje de error :
"No se ha configurado ningún IDP; actualice los metadatos incluidos con al menos un IDP"

Cause

El problema se ha producido porque el archivo .xml de metadatos de IDP no tenía el formato correcto.
En uno de los escenarios, si se incluye un carácter no compatible (por ejemplo, "-"), Tableau Server no podrá identificar la información de IDP necesaria.
-<EntityDescriptor xmlns="urn:oasis:names:tc:SAML:2.0:metadata" entityID="ENTITYID" ID="ID">
-<Signature xmlns="http://www.w3.org/2000/09/xmldsig#">;
-<SignedInfo>
-<Reference URI="#">
-<Transforms>
-<KeyInfo>
-<X509Data>
.
.
.
Solución
 
Trabaje con su administrador de IDP para verificar que el archivo .xml de metadatos de IDP tiene el formato correcto.
Una vez que se haya vuelto a generar, siga los pasos para volver a configurarlo en TSM:
1. Vuelva a intercambiar metadata.xml entre Tableau Server y el IDP.
  • Descargue una nueva versión de metadata.xml desde TSM y cárguela en el IDP (paso 2 y paso 3).
  • Cargue la nueva versión generada de metadata.xml del IDP en TSM (paso 4).
2. Haga clic en "Guardar cambios pendientes" > "Cambios pendientes" en la parte superior de la página > "Aplicar cambios y reiniciar".
*Aplicar cambios pendientes hará que Tableau Server se reinicie. 
Número del artículo de conocimiento

001472510

 
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