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Erreur "SAML Authentication Failed, please contact the administrator" avec "intended destination endpoint ... did not match the recipient" dans les journaux

Date de publication: Aug 24, 2022
Description
Lors de l'accès à Tableau Server avec l'authentification SAML, l'authentification échoue avec le message « SAML Authentication Failed, please contact the administrator. »

Le journal Vizportal peut afficher une erreur du type suivant
Remarque : .com et .net constituent la différence à l'origine de l'erreur dans cet exemple)
2018-04-02 14:29:02.388 -0400 (,,,,) catalina-exec-2 : ERROR org.opensaml.common.binding.decoding.BaseSAMLMessageDecoder - SAML message intended destination endpoint 'http://server.com/wg/saml/SSO/index.html' did not match the recipient endpoint 'http://server.net/wg/saml/SSO/index.html'

Cause

Écart entre la configuration des points de terminaison sur Tableau Server et sur l'IdP.
Résolution
  1. Vérifiez que l'URL de renvoi de Tableau Server est correctement configurée dans l'onglet SAML de la fenêtre de configuration de Tableau Server.
  2. Adressez-vous à l'équipe de votre fournisseur d'identités (IdP) pour vous assurer que le point de terminaison correct a été configuré.
    • Si vous utilisez SAML spécifique à un site, assurez-vous que le point de terminaison pointe vers un point de terminaison spécifique à un site pour chaque site, au lieu du point de terminaison SAML à l'échelle du serveur.
      • Point de terminaison à l'échelle du serveur : https://<tableauserver>/wg/saml/SSO/index.html
      • Point de terminaison spécifique à un site : https://<tableauserver>/samlservice/public/sp/sso?alias=<SpecificPerSiteAlias>
Si vous utilisez un proxy inverse, vérifiez qu'il est configuré pour envoyer l'en-tête d'hôte correct.

 
Numéro d’article de la base de connaissances

001472594

 
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Salesforce Help | Article