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ログ上のエラー "SAML Authentication Failed, please contact the administrator" および "intended destination endpoint ... did not match the recipient"

公開日: Aug 24, 2022
説明
SAML 認証を使用して Tableau Server にアクセスすると、SAML 認証が失敗し、「SAML Authentication Failed, please contact the administrator. (SAML 認証に失敗しました。管理者に連絡してください。)」 というメッセージが表示されます。

次のようなエラーが Vizportal ログに記載されます。
: .com.net の違いがこの例でエラーを引き起こしています。
2018-04-02 14:29:02.388 -0400 (,,,,) catalina-exec-2 : ERROR org.opensaml.common.binding.decoding.BaseSAMLMessageDecoder - SAML message intended destination endpoint 'http://server.com/wg/saml/SSO/index.html' did not match the recipient endpoint 'http://server.net/wg/saml/SSO/index.html' (SAMLメッセージの宛先エンドポイントが受信者エンドポイントと一致しませんでした)

Cause

Tableau Server のエンドポイント構成と IdP の不一致。
解決策
  1. Tableau Server 設定ウィンドウの [SAML] タブで「Tableau Server リターン URL」が正しく設定されていることを確認します。
  2. IdP (アイデンティティ プロバイダー) チームと協力して、正しいエンドポイントが構成されていることを確認します。
    • サイト固有の SAML を使用している場合は、エンドポイントがサーバー全体の SAML エンドポイントではなく、各サイトのサイト固有のエンドポイントを指していることを確認してください。
      • サーバー エンドポイント: https://<tableauserver>/wg/saml/SSO/index.html
      • サイト固有エンドポイント:  https://<tableauserver>/samlservice/public/sp/sso?alias=<SpecificPerSiteAlias>
リバース プロキシを使用している場合は、リバース プロキシが正しいホスト ヘッダーを送信するように構成されていることを確認します。

 
ナレッジ記事番号

001472594

 
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