Loading

Fehler "Access denied for user" (Zugriff für Benutzer verweigert) beim Verbinden mit Google Cloud SQL

Veröffentlichungsdatum: Oct 24, 2022
Beschreibung
Wenn Sie versuchen, eine Verbindung zu Google Cloud SQL herzustellen, kann der folgende Fehler auftreten:
[MySQL][ODBC 5.3(w) Driver]Access denied for user '<user name>'@<Server name or IP address> (using password: YES) ([MySQL][ODBC 5.3(w) Treiber]Zugriff verweigert für Benutzer '<Benutzername>'@<Servername oder IP-Adresse> (Kennwort verwenden: JA))
Invalid username or password. (Ungültiger Benutzername oder ungültiges Kennwort.)

Cause

Dieser Fehler kann eine der folgenden Ursachen haben:
  1. Das Kennwort für die Datenbank enthält Sonderzeichen.
  2. Das Kennwort ist falsch.
  3. SSL ist für die Google Cloud SQL-Instanz erforderlich, aber SSL ist nicht für die Verbindung in Tableau Desktop konfiguriert.
Lösung
Verwenden Sie die folgenden Schritte zur Problembehebung:
  1. Stellen Sie sicher, dass das Kennwort der Datenbank keines der folgenden Sonderzeichen enthält:
    • [] {}() , ; ? * ! @.
  2. Versuchen Sie, von MySQL Workbench aus eine Verbindung zu Google Cloud SQL herzustellen, indem Sie denselben Servernamen und dieselben Anmeldeinformationen verwenden. Wenn Sie mit MySQL Workbench keine Verbindung herstellen können, überprüfen Sie, ob Sie das richtige Kennwort verwenden.
  3. Wenn die oben genannten Schritte das Problem nicht beheben, versuchen Sie, den Connector Andere Datenbanken (ODBC) in Tableau Desktop mit dem MySQL-Treiber zu verwenden: 
  4. Wählen Sie im Dialogfeld des Connectors Andere Datenbanken(ODBC) den MySQL ODBC Unicode-Treiber im Dropdown-Menü aus. 
  5. Klicken Sie auf Verbinden und geben Sie die Verbindungsdaten ein. 
  6. Klicken Sie auf Details >> und wählen Sie die Registerkarte SSL aus. 
  7. Klicken Sie auf ... neben SSL-Schlüssel, SSL-Zertifikat und SSL-Zertifizierungsstelle, um die Dateien client-key.pem, client-cert.pem bzw. server-ca.pem auszuwählen, und klicken Sie dann auf OK.
 
 
Zusätzliche Ressourcen
Weitere Informationen finden Sie unter Diagnose von Problemen mit Cloud SQL-Instanzen.
Nummer des Knowledge-Artikels

001472598

 
Laden
Salesforce Help | Article