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Google Cloud SQL に接続しているときのエラー "Access denied for user (ユーザーのアクセスは拒否されました)"

公開日: Oct 24, 2022
説明
Google Cloud SQL に接続しようとすると、次のエラーが発生する場合があります。
[MySQL][ODBC 5.3(w) Driver]Access denied for user '<user name>'@<Server name or IP address> (using password: YES) (ユーザー '<user name>'@<Server name or IP address> (パスワードの使用: はい) のアクセスは拒否されました)
Invalid Username or Password (ユーザー名またはパスワードが無効です)

Cause

このエラーは、次のいずれかが原因で発生する場合があります。
  1. データベース パスワードに特殊文字が含まれている。
  2. パスワードが正しくない。
  3. Google Cloud SQL インスタンスには SSL が必要であるが、Tableau Desktop で接続のために SSL が構成されていない。
解決策
次のトラブルシューティング手順を試してしてください。
  1. データベース パスワードに次のいずれかの特殊文字が含まれていないことを確認します。
    • [] {}() , ; ? * ! @.
  2. 同じサーバー名と認証資格情報を使用して、MySQL Workbench から Google Cloud SQL に接続してみます。MySQL Workbench を使用して接続できない場合は、正しいパスワードを使用していることを確認してください。
  3. 上記の手順で問題が解決されない場合は、MySQL ドライバーで Tableau Desktop の [その他のデータベース (ODBC)] コネクタを使用してみます。 
  4. [その他のデータベース (ODBC)] コネクタのダイアログ ボックスで、ドロップダウン メニューの [MySQL ODBC Unicode] ドライバーを選択します。 
  5. [接続] をクリックし、接続の詳細を入力します。 
  6. [詳細 >>] をクリックし、[SSL] タブを選択します。 
  7. [SSL Key (SSL キー)][SSL Certificate (SSL 証明書)]、および [SSL Certificate Authority (SSL 証明機関)] の横にある [...] をクリックして、それぞれ client-key.pem、client-cert.pem、および server-ca.pem ファイルを選択し、[OK] をクリックします。
 
 
その他のリソース
詳細については、「Diagnosing Issues with Cloud SQL Instances (Cloud SQL インスタンスに関する問題の診断)」を参照してください。
ナレッジ記事番号

001472598

 
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