Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

Tableau Server アクティブ化時のエラー "The product key <key> has already been activated" (プロダクト キー <key> は既にアクティブ化されています)

公開日: Apr 20, 2023
説明

Tableau Server でプロダクト キーをアクティブ化しようとすると、次のエラーが発生します。

The product key <key> has already been activated (プロダクト キー <key> は既にアクティブ化されています)
 

 

Cause

この動作は、以下のいずれかが原因である可能性があります。 

Tableau Server のプロダクト キーは既にアクティブ化されており、最新ですが、Tableau カスタマー ポータルで表示されるプロダクト キーと Tableau Server で表示されるプロダクト キーが一致しません。  この不一致が発生するのは、サブスクリプションの終了日が到来する前に、新しいサブスクリプション期間が設定された新しいプロダクト キーを Tableau サーバー上で更新および保存した場合です。  前のプロダクト キーの有効期限が切れると、新しいキーが表示されるようになります。 
注: 有効期限日が最も先の日付で Tableau カスタマー ポータルと一致している場合、追加のアクションは不要です。

または 

Tableau Server で、プロダクト キーが保存されているメモリの領域にアクセスできないか、その領域を読み取ることができません。   この状況下では、TSM を使用してキーを表示しても、通常はプロダクト キーが表示されません。
解決策
キーがアクティブ化されていてアクションが不要な場合:

tsm licenses list コマンドを実行するか、TSM UI でキーを確認します。詳細については、「View Server Licenses」(サーバー ライセンスの表示) を参照してください。  プロダクト キーが表示された場合、キーをもう一度アクティブ化することはできません。  キーはアクティブ化されているので、Tableau Server が再起動したのであれば、追加のアクションは不要です。

Tableau カスタマー ポータルとキーが一致しないが、キーの有効期限日が更新されている場合:

 tsm licenses list コマンドを実行または TSM UI でキーを表示した後、プロダクト キーは、Tableau カスタマー ポータルで表示されるキーと一致するように更新はされませんが、サブスクリプション期間の有効期限日は Tableau カスタマー ポータルと一致しています。 追加のアクションは不要です。

メモリに保存されているプロダクト キーを Tableau Server で読み取ることができず、そのキーが TSM に表示されていない場合:
  1. 初期ノードからコマンド プロンプトを開きます。 
  2. Tableau Server の bin ディレクトリに移動します。既定の場所は次のとおりです。
    Linux: /opt/tableau/tableau_server/packages/bin.<version_code>/
    Windows: \Program Files\Tableau\Tableau Server\packages\bin.version_code

  • 以下のコマンドを一度に 1 つずつ実行します。  
    注: これらの手順によって Tableau Server が停止し、ダウンタイムが発生します。
    tsm stop
    ./lmreread  (linux) または lmreread (Windows)
    tsm start
    tsm status -v
その他のリソース
Tableau カスタマー ポータルと Tableau Server でプロダクト キーが一致しない理由については、Tableau コミュニティ ブログで詳しく解説しています。
ナレッジ記事番号

001472676

 
読み込み中
Salesforce Help | Article