Loading

Erreur "connection To Master Server Failed" lors du test de la connexion de l'Agent à l'URL du Serveur principal dans l'enregistrement

Date de publication: Aug 24, 2022
Description

Lorsque vous testez la connexion de l'Agent à l'URL du Serveur principal dans la phase d'enregistrement, la connexion échoue avec l'erreur ci-dessous :

Échec de la connexion à l'URL du Serveur principal

 

Cause

Il se peut que le port 443 soit bloqué par un pare-feu qui empêche les connexions HTTPS à l'ordinateur principal.

Lorsque RMT HTTPS est activé, le certificat auto-signé utilise l'algorithme SHA512, et sur les ordinateurs qui ne le prennent pas en charge, les connexions échouent.

 
Résolution
Plusieurs causes peuvent être à l'origine de cette erreur. Référez-vous aux deux solutions possibles ci-dessous.

Solution 1 :
Autorisez les connexions sortantes du port 443 depuis l'ordinateur de l'Agent, et les connexions entrantes pour le Serveur principal.

Solution 2 :
Ajustez le registre de manière à inclure RSA/SHA512 et ECDSA/SHA512 

1. Ouvrez le registre avec regedit.exe
2. Accédez à HKEY_LOCAL_MACHINE SYSTEM\CurrentControlSet\Control\Cryptography\Configuration\Local\SSL\00010003 Functions
3. Ajoutez les entrées suivantes sur leur propre ligne sous les valeurs existantes : RSA/SHA512 et ECDSA/SHA512
Fonctions cryptographiques
4. Enregistrez et redémarrez l'ordinateur pour que les modifications prennent effet.
 
Ressources supplémentaires
Les journaux de l'Observateur d'événements des applications Windows peuvent afficher une erreur .NET :

Exception : 
System.Net.Http.HttpRequestException: The SSL connection could not be established, see inner exception. (La connexion SSL n'a pas pu être établie, voir l'exception interne.)
 ---> System.Security.Authentication.AuthenticationException: Authentication failed, see inner exception. (Échec de l'authentification, voir l'exception interne.)
 ---> System.ComponentModel.Win32Exception (0x80090308): The token supplied to the function is invalid (Le jeton fourni à la fonction n'est pas valide)
Numéro d’article de la base de connaissances

001472681

 
Chargement
Salesforce Help | Article