Loading

TSM-Initialisierung in Tableau Server schlägt mit Gebietsschema-Fehler fehl

Veröffentlichungsdatum: Dec 9, 2022
Beschreibung

Nach "yum install" von Tableau Server schlägt der nächste Schritt "initialize-tsm" mit einem Gebietsschemafehler fehl:

$ sudo /opt/tableau/tableau_server/packages/script<version>/initialize-tsm --accepteula -a user1 -f

Locale 'en_IN' is not using UTF-8 encoding. (Das Gebietsschema "en_IN" verwendet keine UTF-8-Kodierung.)UTF-8 is required. (UTF-8 ist erforderlich.)
Beispiele für UTF-8-Gebietsschemata sind "en_US.UTF-8" oder "ja_JP.UTF-8" usw. Führen Sie "locale -a" aus, um
eine Liste der unterstützten Gebietsschemata auf Ihrem System anzuzeigen.
Der Vorgang wird abgebrochen.

Cause

Tableau Server wird auf einem System ausgeführt, das eines der folgenden Gebietsschemata verwendet:

de_DE, en_GB, en_US, es_ES, fr_FR, it_IT, ja_JP, ko_KR, pt_BR, zh_CN oder zh_TW.

Andere Gebietsschemata generieren den Fehler.
 

Lösung
Überprüfen Sie das Gebietsschema des Linux-Systems, um sicherzustellen, dass es unter die 11 unterstützten Gebietsschemata fällt. Schlagen Sie unter "Zusätzliche Informationen" nach.

Führen Sie zum Überprüfen des Gebietsschemas des Systems die folgenden Befehle aus:

$  cat /etc/locale.conf
$  localectl


Führen Sie zum korrekten Festlegen des Gebietsschemas die folgenden Befehle aus:

$ sudo yum update systemd  (optional, führen Sie diesen Befehl nur aus, wenn systemd einer alten Version entspricht, die dazu führt, dass der folgende Befehl keine Aktualisierung bewirkt)
$ sudo localectl set-locale LANG=en_US.UTF-8

In einigen Fällen lässt sich das Problem anhand der voranstehend genannten Schritte möglicherweise immer noch nicht lösen. In diesem Fall verwendet die Shell der Linux-Eingabeaufforderung möglicherweise ein angegebenes Gebietsschema. Führen Sie die folgenden Befehle aus, um die Umgebungsvariable für die Shell festzulegen:

$ localedef -c -f UTF-8 -i en_US en_US.UTF-8
$ export LC_ALL=en_US.UTF-8

Führen Sie danach den Befehl "initialize-tsm" erneut aus.

 
Nummer des Knowledge-Artikels

001472682

 
Laden
Salesforce Help | Article