Loading

Fehler: "The sign-in was unsuccessful" und "Response has invalid status code" beim Versuch, sich mittels AD FS-SAML bei Tableau Cloud anzumelden

Veröffentlichungsdatum: Jul 20, 2023
Beschreibung

Bei dem Versuch, sich mittels SAML mit AD FS bei Tableau Cloud anzumelden, tritt der folgende Fehler auf:

The sign-in was unsuccessful. Try again. (Die Anmeldung war nicht erfolgreich. Versuchen Sie es erneut.)

Der folgende Fehler wird auch im Protokoll "tableau_authentication" (es findet sich unter Schritt 7 beim Konfigurieren von SAML für Tableau Cloud) angezeigt.

Response has invalid status code urn:oasis:names:tc:SAML:2.0:status:Responder, status message is null  (Antwort hat ungültigen Statuscode: urn:oasis:names:tc:SAML:2.0:status:Responder, Statusmeldung ist ungültig)

Cause

Der IdP ist nicht richtig dafür konfiguriert, eine gültige Authentifizierungsantwort an Tableau Cloud zu senden.
Lösung
Versuchen Sie es mit den nachstehenden Optionen in der folgenden Reihenfolge, um das Problem zu beheben:

Option 1
  1. Entfernen Sie die nicht unterstützten Bindungstypen (HTTP-Weiterleitung, HTTP-SOAP usw.) aus den IdP-Metadaten.
  2. Importieren Sie die Datei "metadata.xml" wieder in Tableau Cloud.(Unterstützende Informationen finden Sie unter SAML-Anforderungen für Tableau Cloud)

Option 2
  1. Deaktivieren Sie die AD FS-Behauptungsverschlüsselung für die vertrauende Seite.Beachten Sie, dass die Behauptungsverschlüsselung derzeit von Tableau Cloud nicht unterstützt wird.
  2. Verwenden Sie auf dem AD FS-Server die Windows PowerShell, um den folgenden Befehl auszuführen. Ersetzen Sie dabei <MyRelyingPartyName> im nachstehenden Beispielbefehl durch den Anzeigenamen der vertrauenden AD FS-Seite:
Set-ADFSRelyingPartyTrust -TargetName <MyRelyingPartyName> -EncryptClaims 0
  • Hinweis: Wird der Fehler "Set-ADFSRelyingPartyTrust Cmdlet cannot be found" angezeigt, müssen Sie das AD FS PowerShell-Snap-in hinzufügen.Geben Sie an der Eingabeaufforderung Folgendes ein, und wiederholen Sie diesen Schritt.
Add-PSSnapin Microsoft.Adfs.PowerShell

Option 3 
  1. In den AD FS-Protokollen wird der folgende Fehler angezeigt:"ID4037: Der zum Überprüfen der Signatur erforderliche Schlüssel konnte aus dem Sicherheitsschlüsselbezeichner 'SecurityKeyIdentifier' nicht aufgelöst werden."
  2. Führen Sie die Schritte 1–3 unter Konfigurieren von SAML mit AD FS aus, um eine Diskrepanz zwischen den Zertifikaten für den IdP und Tableau Cloud zu korrigieren.

Option 4
Wenden Sie sich zwecks Unterstützung an Ihren IdP-Anbieter, um herauszufinden, warum die SAML-Antwort den Status Responder anstelle von Success anzeigt, da er am besten ermitteln kann, was mit dem Austausch ist, für den keine Konfiguration besteht.
Zusätzliche Ressourcen
Zusätzliche Informationen finden Sie in diesem Microsoft-Artikel.

Hinweis: Trotz unserer Bestrebungen, die Referenzen zu den Inhalten von Drittanbietern auf aktuellem Stand zu halten, können sich die hier aufgeführten Informationen ohne Vorankündigung ändern.


Nummer des Knowledge-Artikels

001472786

 
Laden
Salesforce Help | Article