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Erreur "The sign-in was unsuccessful" et "Response has invalid status code" lors de la tentative de connexion à Tableau Cloud à l'aide d'ADFS SAML

Date de publication: Jul 20, 2023
Description

Lors de la tentative de connexion à Tableau Cloud à l'aide de SAML avec AD FS, l'erreur suivante se produit :

The sign-in was unsuccessful. Try again. (Échec de la connexion. Réessayez)

L'erreur ci-dessous s'affiche également dans le journal tableau_authentication (qui se trouve sous Étape 7 lorsque vous configurez SAML sur Tableau Cloud).

Response has invalid status code urn:oasis:names:tc:SAML:2.0:status:Responder, status message is null  (Code d'état non valide de la réponse urn:oasis:names:tc:SAML:2.0:status:Responder, message d'état null)

Cause

L'IdP n'est pas correctement configuré pour envoyer une réponse d'authentification valide à Tableau Cloud. 
Résolution
Essayez les étapes ci-dessous, dans l'ordre suivant, pour résoudre le problème :

Option 1
  1. Supprimez tout type de liaison non pris en charge (HTTP-Redirect, HTTP-SOAP, etc) des métadonnées de l'IdP.
  2. Réimportez le fichier metadata.xml dans Tableau Cloud. (Voir Exigences SAML pour Tableau Cloud pour des informations annexes)

Option 2
  1. Désactivez le cryptage d'assertion AD FS pour la partie de confiance. Notez que Tableau Cloud ne prend pas en charge actuellement le cryptage d'assertion.
  2. Sur le serveur AD FS, utilisez Windows PowerShell pour exécuter la commande suivante, en remplaçant <MyRelyingPartyName> dans l'exemple ci-dessous par le  nom d'affichage de la partie de confiance ADS :
Set-ADFSRelyingPartyTrust -TargetName <MyRelyingPartyName> -EncryptClaims 0
  • Remarque : si vous recevez l'erreur « Set-ADFSRelyingPartyTrust Cmdlet cannot be found », vous devez ajouter le composant logiciel enfichable AD FS PowerShell.À l'invite de commande, tapez ce qui suit, puis répétez cette étape.
Add-PSSnapin Microsoft.Adfs.PowerShell

Option 3 
  1. L'erreur suivante se produit dans les journaux AD FS : "ID4037: The key needed to verify the signature could not be resolved from the following security key identifier 'SecurityKeyIdentifier'" (ID4037 : La signature avait besoin de vérifier que la signature ne pouvait pas être résolue depuis l'identificateur de clé de sécurité suivant « SecurityKeyIdentifier ».)
  2. Suivez les étapes 1-3 de la section Configurer SAML avec AD FS pour corriger une non-correspondance dans les certificats sur l'IdP et Tableau Cloud. 

Option 4
Contactez votre fournisseur IdP pour qu'il vous aide à examiner pourquoi la réponse SAML renvoie un état Répondeur au lieu de Succès. Il représente la meilleure ressource pour déterminer les échanges qu'il n'est pas configuré à accepter.
Ressources supplémentaires
Veuillez vous référer à cet article de Microsoft pour plus d'informations.

Remarque : bien que nous fassions tous les efforts possibles pour que les références au contenu tiers soient précises et à jour, les informations fournies ici peuvent changer sans préavis.


Numéro d’article de la base de connaissances

001472786

 
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