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Tableau Cloud へ ADFS SAML を使用してログインを試行するときのエラー "The sign-in was unsuccessful" および "Response has invalid status code"

公開日: Jul 20, 2023
説明

AD FS を使用した SAML を用いて Tableau Cloud にログインしようとすると、次のエラーが発生します。

サインインに失敗しました。もう一度やり直してください。

tableau_authentication ログ (Tableau Cloud で SAML を構成するときのステップ 7 で参照できます) に以下のエラーも表示されます。

Response has invalid status code urn:oasis:names:tc:SAML:2.0:status:Responder, status message is null  (応答に無効なステータス コードが含まれています urn:oasis:names:tc:SAML:2.0:status: 応答者、ステータス メッセージが NULL です )

Cause

IdP は Tableau Cloud に有効な認証応答を送信するよう適切に構成されていません。
解決策
問題を解決するには、以下のオプション次の順序で試してください。

オプション 1
  1. サポートされていないバインディングのタイプ (HTTP-リダイレクト HTTP-SOAP など) を IdP メタデータから削除します。
  2. metadata.xml を Tableau Cloud にもう一度インポートします。(サポート情報については、 「Tableau Cloud の SAML 要件」 を参照してください。)

オプション 2
  1. Relying Party に対する AD FS アサーションの暗号化をオフにします。Tableau Cloud では、現在アサーションの暗号化はサポートされていないことに注意してください。
  2. AD FS サーバーで、Windows PowerShell を使用して次のコマンド実行し、以下のコマンド入力例に含まれる <MyRelyingPartyName> を、ADFS relying party の表示名に置き換えます。
Set-ADFSRelyingPartyTrust -TargetName <MyRelyingPartyName> -EncryptClaims 0
  • 注: "Set-ADFSRelyingPartyTrust Cmdlet が見つかりません" というエラーが表示される場合は、AD FS PowerShell snap-in を追加する必要があります。以下のコマンド プロンプトでこのステップを繰り返します。
Add-PSSnapin Microsoft.Adfs.PowerShell

オプション 3
  1. AD FS ログで次のエラーが発生します。"ID4037: 次のセキュリティ キー識別子 'SecurityKeyIdentifier'" から署名の確認に必要なキーを解決できませんでした。
  2. AD FS を使用した SAML の構成のステップ 1 ~ 3 に従い、IdP および Tableau Cloud で証明書の不一致を修正します。

オプション 4
IdP プロバイダーに連絡して、SAML の応答がなぜ成功ではなく応答者 ステータスをスローしているのかを調査するよう依頼します。IdP プロバイダーは、受け入れるように設定されていないステータスにどのように入れ替わったのかを特定できる最高の情報源です。
その他のリソース
詳細については、この Microsoft の記事 を参照してください。

: サードパーティー コンテンツが正確で最新のものであるように確認する最善の努力を払っていますが、ここに参照される情報は、予告なしに変更される可能性があります。


ナレッジ記事番号

001472786

 
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