Loading

Error "no such file or directory" al ejecutar el comando initialize tsm

Fecha de publicación: Apr 3, 2023
Descripción
Al instalar Tableau Server en Linux, el comando initialize-tsm no funciona y muestra el siguiente error:

 "no such file or directory" (Ese archivo o directorio no existen)

Además, puede encontrarse uno de los errores siguientes en el archivo app-install.log:
 
ERROR com.tableausoftware.installer.InstallerMain - Generic exception raised during installation.
java.lang.RuntimeException: java.net.UnknownHostException: ip-<IP ADDRESS>: ip-<IP ADDRESS>: Temporary failure in name resolution (java.lang.RuntimeException: java. ERROR com.tableausoftware.installer.InstallerMain - Excepción genérica surgida durante la instalación. net.UnknownHostException: ip-<DIRECCIÓN IP>: ip-<DIRECCIÓN IP>: error temporal en la resolución del nombre)


O
 
main: ERROR com.tableausoftware.service.LinuxServiceManager - sudo: sorry, you must have a tty to run sudo (principal: ERROR com.tableausoftware.service.LinuxServiceManager - sudo: debe tener un tty para ejecutar sudo)

Cause

Según el mensaje de error que haya en los registros, o hay un problema con la configuración de red local, o se requería tty.
Solución

Opción 1: error temporal en la resolución del nombre

Contacte con el equipo de TI local para asegurarse de que la red esté bien configurada y de que el nombre de host del servidor sea capaz de resolverse cuando se haga ping. Es posible que el servidor DNS o DHCP esté mal configurado. Para obtener más información, consulte Serverfault: Temporary failure in name resolution (en inglés) en StackOverflow.

Opción 2: debe tener un tty para ejecutar el error sudo

Para desactivar requiretty globalmente:

  1. Remplace Defaults requiretty con Defaults !requiretty en sus /etc/sudoers. Esto afectará a su configuración de sudo global.
  2. Deshabilite tty y vuelva a ejecutar el sudo ./initialize-tsm --accepteula.
Recursos adicionales
sudo: sorry, you must have a tty to run sudo (en inglés) en Shell Tips!


Comente sobre este artículo... Foro de comentarios
Número del artículo de conocimiento

001472892

 
Cargando
Salesforce Help | Article