Loading

Error "Timeout Error: IPC_NamedPipe::Select(WaitForMultipleObjects)" al conectarse a los datos o al trabajar con las extracciones

Fecha de publicación: Jul 20, 2023
Descripción
Al intentar conectarse a una fuente de datos, o crear o actualizar extracciones con Tableau Desktop, aparece el mensaje de error siguiente:
 
 IPC_NamedPipe::Select(WaitForMultipleObjects): Timeout. (IPC_NamedPipe::Select(WaitForMultipleObjects): Tiempo de espera agotado)

Cause

El software antivirus impide que se ejecuten los procesos de Tableau, la carpeta Registros contiene información dañada o el repositorio de Tableau Desktop no se encuentra instalado en el disco local.
Solución

Opción 1:

Colabore con el equipo de TI para añadir las carpetas y procesos de Tableau a las exclusiones:
  • Tableau.exe
  • hyperd.exe
  • hyperdstarter.exe
  • Extensión *.hyper (si el antivirus tiene la opción de excluir extensiones)
  • C:\Users\<nombreDeUsuario>\Documents\My Tableau Repository
  • C:\Usuarios\<nombreDeUsuario>\AppData\Local\Temp\TableauTemp
  • C:\Usuarios\<nombreDeUsuario>\AppData\Local\Tableau
  • C:\Program Files\Tableau
    • Asegúrese de incluir las carpetas secundarias en las exclusiones. Cada programa antivirus puede ofrecer una opción distinta para hacer esto, como el uso de comodines en la ruta (*) o una opción explícita para añadir carpetas secundarias.
Nota: las rutas anteriores se refieren a una instalación predeterminada de Tableau Desktop. Si Tableau Desktop se ha instalado en una ubicación que no es la predeterminada o la carpeta Mi Repositorio de Tableau se ha cambiado de sitio, asegúrese de que las exclusiones coincidan con las rutas correspondientes de la instalación no predeterminada.

Para que estas exclusiones estén configuradas para una cobertura total y surtan efecto:
  1. Incluya las rutas y los programas anteriores en exclusiones para todas las configuraciones de análisis y, si el antivirus tiene una lista específica de "Programas de confianza", añádale los archivos .exe.
  2. Reinicie el equipo afectado.

Opción 2:

  1. Cierre Tableau Desktop.
  2. Vaya al Mi Repositorio de Tableau y cambie el nombre de la carpeta de registros a Logs_Backup.
  3. Vuelva a abrirTableau Desktop.

Opción 3:

  1. Cierre Tableau Desktop.
  2. Cambie la ubicación del repositorio de Tableau Desktop de la unidad de red al disco local del equipo que ejecuta Tableau Desktop.
  3. Vuelva a abrirTableau Desktop.
Recursos adicionales
Busque en la carpeta C:\Users\<nombre de usuario>\Documents\My Tableau Repository\Logs si se ha creado un archivo "hyperd.log". Si el archivo no está presente, el software antivirus podría bloquear el inicio del hiperproceso, que es específico de Tableau Desktop 10.5 y versiones posteriores.

Número del artículo de conocimiento

001472912

 
Cargando
Salesforce Help | Article