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Erreur "Timeout Error: IPC_NamedPipe::Select(WaitForMultipleObjects)" lors de la connexion aux données ou de l'utilisation d'extraits

Date de publication: Jul 20, 2023
Description
Lorsque vous tentez de vous connecter à une source de données ou de créer et/ou d'actualiser des extraits avec Tableau Desktop, le message d'erreur suivant s'affiche :
 
 IPC_NamedPipe::Select(WaitForMultipleObjects): Timeout. (Délai expiré)

Cause

Un logiciel antivirus bloque l'exécution des processus Tableau ou le dossier Logs contenait des informations endommagées, ou encore l'emplacement du répertoire Tableau Desktop ne se trouve pas sur le disque local.
Résolution

Option 1 :

Adressez-vous à votre département informatique pour ajouter des dossiers et des processus Tableau aux exclusions :
  • Tableau.exe
  • hyperd.exe
  • hyperdstarter.exe
  • Extension *.hyper (si l'AntiVirus a une option d'exclusion d'extensions)
  • C:\Users\<username>\Documents\My Tableau Repository
  • C:\Users\<username>\AppData\Local\Temp\TableauTemp
  • C:\Users\<username>\AppData\Local\Tableau
  • C:\Program Files\Tableau
    • Assurez-vous que les dossiers enfants sont inclus dans les exclusions. Les programmes AntiVirus peuvent avoir des options différentes uniques au programme, par exemple l'utilisation de caractères génériques (*), ou une option explicite d'ajout de dossiers enfants.
Remarque : les chemins ci-dessus sont basés sur une installation par défaut de Tableau Desktop. Si Tableau Desktop a été installé dans un emplacement non par défaut, et/ou que le dossier Mon répertoire Tableau a été redéfini, assurez-vous que les exclusions correspondent aux chemins correspondant d'une installation non par défaut.

Pour être sûr que ces exclusions sont définies pour toute la couverture et appliquées :
  1. Incluez les chemins d'accès et les programmes suivants dans les exclusions pour tous les paramètres de balayage, et si l'AntiVirus inclut une liste spécifiquement pour les « Programmes de confiance », ajoutez les fichiers .exe ici.
  2. Redémarrez l'ordinateur concerné.

Option 2 :

  1. Fermez Tableau Desktop.
  2. Accédez à Mon référentiel Tableau et renommez le dossier Logs en Logs_Backup. 
  3. Ouvrez à nouveau Tableau Desktop.

Option 3 :

  1. Fermez Tableau Desktop.
  2. Modifiez l'emplacement du référentiel Tableau Desktop d'un lecteur réseau sur le disque local d'un ordinateur Tableau Desktop.
  3. Ouvrez à nouveau Tableau Desktop.
Ressources supplémentaires
Vérifiez le dossier C:\Users\<username>\Documents\My Tableau Repository\Logs pour voir si un fichier « hyperd.log » a été créé. Si le fichier n'est pas présent, cela indique que le logiciel antivirus bloque peut-être le démarrage du processus hyper, ce qui est spécifique à Tableau Desktop 10.5 et ultérieur.

Numéro d’article de la base de connaissances

001472912

 
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