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Errore "Timeout Error: IPC_NamedPipe::Select(WaitForMultipleObjects)" durante la connessione ai dati o quando si lavora con le estrazioni

Data pubblicazione: Jul 20, 2023
Descrizione
Quando tenti di connetterti a un'origine dati o di creare e/o aggiornare estrazioni con Tableau Desktop, si verifica il seguente messaggio di errore:
 
 IPC_NamedPipe::Select(WaitForMultipleObjects): Timeout.

Cause

Il software antivirus sta bloccando l'esecuzione dei processi di Tableau, la cartella Log contiene informazioni danneggiate o la posizione del repository di Tableau Desktop non si trova sul disco locale.
Risoluzione

Opzione 1:

Collabora con l'IT per aggiungere cartelle e processi Tableau alle esclusioni:
  • Tableau.exe
  • hyperd.exe
  • hyperdstarter.exe
  • estenzioni *.hyper (se AntiVirus ha un'opzione per le esclusioni di estensione)
  • C:\Users\<username>\Documents\My Tableau Repository
  • C:\Users\<nomeutente>\AppData\Local\Temp\TableauTemp
  • C:\Users\<nomeutente>\AppData\Local\Tableau
  • C:\Program Files\Tableau
    • Assicurati che le cartelle figlio siano incluse nelle esclusioni. I programmi antivirus possono disporre di diverse opzioni per farlo specifiche per questo programma, come l'utilizzo di caratteri jolly nel percorso (*), o un'opzione esplicita per aggiungere cartelle figlio.
Nota: I percorsi di cui sopra si basano su un'installazione predefinita di Tableau Desktop. Se Tableau Desktop è stato installato in una posizione non predefinita e/o la cartella My Tableau Repository è stata ridefinita, assicurati che le esclusioni corrispondano ai percorsi corrispondenti dell'installazione non predefinita.

Per assicurarti che queste esclusioni siano impostate per una copertura completa e abbiano effetto:
  1. Includi i percorsi e i programmi precedenti nelle esclusioni per tutte le impostazioni di scansione, e se l'AntiVirus ha un elenco specifico per "Programmi attendibili", aggiungi il file .exe in quella posizione.
  2. Riavvia il computer interessato.

Opzione 2:

  1. Chiudi Tableau Desktop.
  2. Passa al My Tableau Repository e rinomina la cartella Log in Logs_Backup. 
  3. Riapri Tableau Desktop.

Opzione 3:

  1. Chiudi Tableau Desktop.
  2. Modifica la posizione del repository di Tableau Desktop da un'unità di rete al disco locale sul computer Tableau Desktop.
  3. Riapri Tableau Desktop.
Risorse aggiuntive
Verifica la cartella C:\Users\<username>\Documents\My Tableau Repository\Logs per vedere se è stato creato un file "hyperd.log". Se il file non è presente, significa che il software antivirus potrebbe bloccare l'avvio del processo Hyper, che è specifico per Tableau Desktop 10.5 e versioni successive.

Numero articolo Knowledge

001472912

 
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