Loading

Errore "LM_REPAIR_NEEDED" durante l'attivazione di Tableau Desktop

Data pubblicazione: Jul 20, 2023
Descrizione
Durante l'attivazione di Tableau Desktop, può verificarsi il seguente errore:
Checkout failed: lc_checkout return information -157
(LM_REPAIR_NEEDED) (Checkout non riuscito: informazioni restituite da lc_checkout -157 - LM_REPAIR_NEEDED)

Cause

Un identificatore univoco della macchina, ad esempio il numero di serie del disco di avvio, l'indirizzo MAC o l'ID macchina virtuale, è stato modificato dopo l'avvio della versione di prova o dopo l'attivazione di Tableau Desktop.
Utilizzando l'opzione Desktop virtuale, l'immagine master non può essere attivata prima della creazione della macchina virtuale o del clone.  
Risoluzione
Se il desktop virtuale è stato configurato, passa alla parte II. In caso contrario, completa solo la parte I.

Parte I:

Per risolvere questo problema, esegui la procedura descritta in Risolvere gli errori di licenza FlexNet durante l'attivazione o l'apertura di Tableau Desktop
Nota: Per la procedura in cui viene utilizzato il prompt dei comandi, esegui il prompt dei comandi come amministratore.

Se questi passaggi non consentono di risolvere il problema, crea un caso di assistenza e fornisci le seguenti informazioni:
  1. Dati della licenza per i desktop non virtuali. Per maggiori informazioni, vedi Comunicazione dei dati della licenza all'Assistenza Tableau.
  2. Log di Tableau Desktop. Per maggiori informazioni, consulta Invio dei file di log di Tableau Desktop.

Parte II - Flag ATR del desktop virtuale impostato

Questo errore si verifica in una delle macchine virtuali dell'utente finale, quando l'immagine master è stata attivata. In questo caso, le macchine virtuali dovranno essere ricreate in base alla procedura seguente:
  1. Ripristina l'immagine master allo stato precedente all'installazione di Tableau Desktop.
  2. Aggiorna l'immagine master per reinstallare Tableau Desktop con le opzioni della riga di comando per il desktop virtuale (consulta Configurare Supporto desktop virtuale) e non attivare una chiave.
  3. Crea le nuove macchine virtuali dell'utente finale.
La macchina virtuale dell'utente finale non deve essere attivata al momento della creazione e della distribuzione. L'attivazione verrà eseguita dall'utente finale, accedendo alla macchina virtuale o tramite uno script che attiva la macchina virtuale per conto dell'utente finale.

Se non è possibile eseguire il rollback dell'immagine master allo stato precedente all'installazione di Tableau Desktop, contatta l'assistenza e fornisci le seguenti informazioni: 
  1. Recupera i dati della licenza dall'immagine master; includi i file sia dei desktop virtuali che dei desktop non virtuali. Per maggiori informazioni, vedi Comunicazione dei dati della licenza all'Assistenza Tableau.
  2. Dall'immagine master, i log di Tableau Desktop. Per maggiori informazioni, consulta Invio dei file di log di Tableau Desktop.
  3. Dalla macchina virtuale dell'utente finale, fornisci i dati della licenza non Desktop virtuale. Per maggiori informazioni, vedi Comunicazione dei dati della licenza all'Assistenza Tableau.
Queste informazioni sono necessarie perché non è possibile disattivare un codice prodotto quando è stata impostata l'opzione Desktop virtuale di Tableau.
Risorse aggiuntive

Numero articolo Knowledge

001472913

 
Caricamento
Salesforce Help | Article