Loading

Error intermitente "Invalid username or password" al iniciar sesión en Tableau Server de varios nodos con SAML

Fecha de publicación: Jul 20, 2023
Descripción
Después de realizar un cambio en el IdP o Tableau Server que requiere que se importen nuevos metadatos de IdP, es posible que aparezca un mensaje de error intermitente que dice "Invalid username or password" (El nombre de usuario o la contraseña no son válidos) al iniciar sesión en Tableau Server con SAML.

Al investigar los registros de VizPortal, podrá ver que si bien las respuestas de SAML del IdP que administra el nodo principal son correctas, las que administra el nodo trabajador no lo son. Es posible que aparezcan errores similares a los siguientes: 
org.apache.xml.security.signature.XMLSignature - Signature verification failed (Error al verificar la firma).
org.springframework.security.saml.websso.WebSSOProfileConsumerImpl - Validation of received assertion failed, assertion will be skipped (org.springframework.security.saml.websso.WebSSOProfileConsumerImp: la validación de la aserción recibida produjo errores, se omitirá la aserción).
org.opensaml.xml.validation.ValidationException: Signature is not trusted or invalid (Excepción org.opensaml.xml.validation.Validation: la firma no es de confianza o válida.

Nota: los mensajes de error varían según la parte de los metadatos donde no haya coincidencias.

Cause

VizPortal usa el archivo de metadatos del IdP para verificar la firma en la confirmación de entrada.  Los cambios en los metatados modificaron la firma. Por eso, si VizPortal usa los metadatos anteriores, la firma no será válida. 
Solución
Copie los nuevos metadatos del IdP a todos los nodos trabajadores que alojen un proceso de VizPortal. 
Los metadatos del IdP deben estar en la misma ruta absoluta en los nodos trabajadores que en el principal. 
Por ejemplo, si se almacena el archivo .XML de metadatos en el principal en C:\Program Files\Tableau\Tableau Server\SAML\, el archivo de metadatos del IdP en los nodos trabajadores deben estar en C:\Program Files\Tableau\Tableau Server\SAML\.  Esta ruta es literal y no se hace referencia a ella en relación con la ruta de instalación del software del trabajador.
Si se efectuaran cambios en la combinación de claves o certificados de SAML, también se deben aplicar a todos los trabajadores que alojan un proceso de VizPortal en la misma ruta literal que el nodo principal.
Recursos adicionales
El error que se produce puede variar si la información de la firma en los nuevos metadatos es igual, pero otra es diferente.


Número del artículo de conocimiento

001472934

 
Cargando
Salesforce Help | Article