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Fehler "Cannot extract required information from IDCRL header" (Erforderliche Informationen können nicht aus dem IDCRL-Header extrahiert werden) bei Verbindung mit SharePoint-Liste

Veröffentlichungsdatum: Jul 20, 2023
Beschreibung
Bei dem Versuch, eine Verbindung mit einer SharePoint-Liste herzustellen, kann der folgende Fehler auftreten:

Client unable to establish connection Cannot extract required information from IDCRL header, Header=, IdcrlType=, ServicePolicy=, ServiceTarget=, Endpoint= (Client kann keine Verbindung herstellen, erforderliche Informationen aus dem IDCRL-Header, Header=, IdcrlType=, ServicePolicy=, ServiceTarget=, Endpoint= können nicht extrahiert werden)

Cause

Ursache 1:
Im Dialogfeld für den SharePoint-Listen-Connector ist die falsche Edition ausgewählt, oder es wird ein nicht unterstütztes Fremdanbieter-SSO-Produkt verwendet.

Ursache 2:
Es bestehen Konnektivitätsprobleme zwischen Tableau Server und der SharePoint-Site (d. h. die Navigation zur SharePoint-Site über den Browser gibt einen Fehler zurück).
Lösung
Lösung 1:
Überprüfen Sie zusammen mit Ihrem IT-Team, ob im Dialogfeld für den SharePoint-Listen-Connector die richtige Edition ausgewählt ist. Sie sollte Lokal lauten, falls der obige Fehler auftritt, wenn Benutzername und Kennwort als Methode für die Authentifizierung festgelegt ist.

Wenn Fremdanbieter-SSO als Methode für die Authentifizierung festgelegt ist, sollten Sie überprüfen, ob ein unterstütztes Fremdanbieter-SSO-Produkt verwendet wird.

Lösung 2:
Arbeiten Sie mit dem IT-Team zusammen, um Probleme mit der Netzwerkverbindung zu beheben.
Zusätzliche Ressourcen
Die SSO-Fremdanbieterprodukte, die derzeit mit dem SharePoint-Listen-Connector unterstützt werden, sind OneLogin und Okta.

Zur Behebung von Problemen mit der Netzwerkkonnektivität können Sie Tools wie Wireshark und/oder Fiddler verwenden, um Protokolle zu sammeln.

1. Generieren Sie ein Wireshark-Protokoll, das den Datenverkehr in Tableau Server während einer versuchten Aktualisierung der SharePoint-Datenquelle aufzeichnet. Im Protokoll sehen Sie, dass kurz nach dem DNS-Lookup der SharePoint-Site die Verbindung zurückgesetzt wird, was zum Fehlschlagen des Extrakts führt.

2. Verwenden Sie Fiddler, um einen Ladeversuch der SharePoint-Site in einem Browser zu erfassen.

Nummer des Knowledge-Artikels

001472946

 
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