Loading

Error "Cannot extract required information from IDCRL header (No se puede extraer la información requerida del encabezado IDCRL)" al conectarse a la lista de SharePoint.

Fecha de publicación: Jul 20, 2023
Descripción
Al intentar conectarse a una lista de SharePoint, podría producirse el siguiente error:

Client unable to establish connection Cannot extract required information from IDCRL header, Header=, IdcrlType=, ServicePolicy=, ServiceTarget=, Endpoint= (El cliente no pudo establecer la conexión. No se pudo extraer la información necesaria del encabezado IDCRL, Header=, IdcrlType=, ServicePolicy=, ServiceTarget=, Endpoint=).

Cause

Causa 1:
Se ha seleccionado la Edición incorrecta en el cuadro de diálogo del conector de listas de SharePoint o se está utilizando un producto de SSO de terceros no compatible.

Causa 2:
Existen problemas de conectividad entre Tableau Server y el sitio de SharePoint (es decir, desplazarse al sitio de SharePoint mediante el navegador mostrará un error).
Solución
Solución 1:
Hable con su equipo de TI para comprobar que se ha seleccionado la Edición correcta en el cuadro de diálogo del conector de listas de SharePoint: debería ser On Premise si el error se produce cuando el método de Autenticación es Nombre de usuario y contraseña.

Si el método de Autenticación es SSO de terceros, compruebe que se utiliza un producto de SSO de terceros compatible.

Solución 2:
Trabaje con el equipo de TI para solucionar los problemas de conexión de la red.
Recursos adicionales
OneLogin y Okta son los productos de SSO de terceros compatibles actualmente con el contector de listas de SharePoint.

Para solucionar problemas de conectividad de la red, puede usar herramientas como Wireshark o Fiddler para recopilar registros.

1. Genere un registro de Wireshark que recopile el tráfico de Tableau Server durante un intento de actualización de la fuente de datos de SharePoint. En el registro, verá que, poco después de la búsqueda de DNS en el sitio de SharePoint, se restablecerá la conexión, que es lo que causa que falle la extracción.

2. Utilice Fiddler para capturar un intento de carga del sitio de SharePoint en un navegador.

Número del artículo de conocimiento

001472946

 
Cargando
Salesforce Help | Article