When attempting to connect to SharePoint Lists, the following error may occur:
Client unable to establish connection Cannot extract required information from IDCRL header, Header=, IdcrlType=, ServicePolicy=, ServiceTarget=, Endpoint=
Cause 1:
The incorrect Edition is selected in the SharePoint Lists connector dialog box, or an unsupported third-party SSO product is used.
Cause 2:
There are connectivity issues between the Tableau Server and the SharePoint site (i.e. navigating to the SharePoint site through the browser will return an error)
Cause 3:
An external firewall for the datacenter that was hosting the SharePoint server is blocking the connection from Tableau. This can happen when connecting to SharePoint Online over a VPN.
Solution 1:
Work with your IT team to verify that the correct Edition is selected in the SharePoint Lists connector dialog box: it should be On Premise if the above error occurs when the Authentication method is Username and Password.
If the Authentication method is Third-party SSO, verify that a supported third-party SSO product is used. Note that the only SSO supported by Tableau for SharePoint Lists connection are OneLogin and Okta, but others may happen to work.
Solution 2:
Work with IT team to troubleshoot network connection issues.
Solution 3:
Create an external firewall exception for Tableau, after which the connection to SharePoint should be successful.
The third-party SSO products that are currently supported with the SharePoint Lists connector are OneLogin and Okta.
For troubleshooting network connectivity issues, you may use tools such as Wireshark and/or Fiddler to gather logs
1. Generate a Wireshark log that captures the traffic on Tableau Server during an attempted refresh of the SharePoint data source. In the log, you will see that shortly after the DNS lookup of the SharePoint site there will be a reset connection, which is what is triggering the extract to fail.
2. Use Fiddler to capture an attempted load of the SharePoint site in a browser.
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