Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

抽出更新時のエラー "Unable to connect to the file "<file path>". Check that the file exists and that you have sufficient access privileges for it."

公開日: Aug 24, 2022
説明
ネットワーク ドライブ上にある Excel ファイルの抽出を更新すると、抽出に失敗し、[バックグラウンド タスク] ビューに次のエラーが表示されます。

com.tableausoftware.nativeapi.dll.DataSourceException: Unable to connect to the file "<file path>".  Check that the file exists and that you have sufficient access privileges for it. (ファイル "<file path>" に接続できません。ファイルが存在し、ファイルに対する十分なアクセス権限があることを確認してください。)

Cause

ファイルが移動または削除されたか、Tableau Server の実行ユーザーにファイルの保存場所へのアクセス権がありません。これは、データ ソースへの接続に使用するパスがマップ済みのパスであることが原因であると考えられます。実行ユーザーのアカウントで別のユーザーのセキュリティ コンテキストで認証されているリソースにアクセスできないため、マップ済みのパスを使用できません。


 
解決策
  • ファイルが予期した場所に配置されていることを確認します。
  • Tableau Desktop のデータ接続を更新し、マップ済みのドライブ文字を含むファイル パスではなく UNC パスを Excel ワークブックに反映させてからワークブックを再パブリッシュします。
  • Tableau Server の実行ユーザーに、ファイルの保存場所へのアクセス権があることを確認します。
Tableau Server の実行ユーザーにファイルの場所へのアクセス権があるかどうかをテストするには、'実行' ユーザーとして Tableau Server を実行しているコンピューターにログインし、Windows File Explorer ウィンドウで UNC パスを使用してファイルが保存されているフォルダーへのアクセスを試行してください。

 
その他のリソース
ArcGIS.com の UNC パスに関する説明と例
ナレッジ記事番号

001473009

 
読み込み中
Salesforce Help | Article