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Tableau Server Hosted on AWS Error: "Unknown Server Error" or "Unexpected Server Error" When Accessing a Workbook

Date de publication: May 5, 2026
Description
When accessing a workbook on Tableau Server hosted on AWS, the workbook fails to load and the following error messages might occur: 
Unknown Server Error
'An unexpected error occurred. If you continue to receive this error please contact your Tableau Server Administrator.'
Or
Unexpected Server Error
'An error occurred communicating with the server (504). This may be a temporary network condition. Please retry the operation. If this condition persists, contact your system administrator.'

Cause

The connection to AWS times out due to timeout settings in the elastic load balancer. 
Résolution

To stop the failures "Unknown Server Error" or "Unexpected Server Error" when Tableau is hosted on AWS, increase the idle timeout on the AWS elastic load balancer. The default value is 60 seconds which can be increased up to 3600 seconds (1 hour).

Ressources supplémentaires
For more information about idle connection timeout, see Configure the Idle Connection Timeout for Your Classic Load Balancer.


 
Numéro d’article de la base de connaissances

001473070

 
Chargement
Salesforce Help | Article