Loading

Erreur « There was an unexpected error while trying to repair Trusted Storage » (Une erreur inattendue s'est produite lors de la tentative de réparation du stockage de confiance) lors de l'activation ou de l'installation sur un Mac

Date de publication: Jul 20, 2023
Description
Lorsque vous essayez d'activer Tableau Desktop, les erreurs suivantes peuvent se produire :

Une erreur inattendue s'est produite lors de la tentative de réparation de Trusted Storage.

ou 

Function flxActCommonRepairLocalTrustedStorage returned error (50044, 71013, 19810) (La fonction flxActCommonRepairLocalTrustedStorage a renvoyé une erreur (50044, 71013, 27))
LM_TS_LOCAL_REPAIR
There was an unexpected error while trying to repair Trusted Storage. (Une erreur inattendue s'est produite lors de la tentative de réparation du stockage de confiance.)


ou 

Function flxActCommonRepairLocalTrustedStorage returned error (50044, 71013, 27) (La fonction flxActCommonRepairLocalTrustedStorage a renvoyé une erreur (50044, 71013, 27))
LM_TS_LOCAL_REPAIR
There was an unexpected error while trying to repair Trusted Storage. (Une erreur inattendue s'est produite lors de la tentative de réparation du stockage de confiance.)


ou

ERROR: flxActCommonLicSpcPopulateAllFromTS (50030, 71521,17005)
lorsque vous essayez d'examiner le stockage de confiance à l'aide de custactutil
 

Cause

Ce problème peut avoir lieu dans différentes circonstances :
  • Outils ou systèmes tiers interférant avec les fichiers et répertoires Tableau.
  • Problèmes de corruption avec les données de licence FlexNet.
  • Sauvegardes Time Machine et déplacement d'images Tableau Desktop.
Pour éviter ce problème, travaillez avec votre équipe informatique pour vous assurer qu'aucun service ou compte géré ne modifie les fichiers Tableau, y compris les fichiers FlexNet pertinents.
 
Résolution

Option 1 - Pour Tableau Desktop 2019.3 et versions ultérieures

Réexécutez le programme d'installation, car il n'est plus possible de scinder le package Flexnet. 


Option 2 - Pour toutes les versions de Tableau Desktop

Please note that using the below method may impact other applications that also run with FLEXnet. Consult with your IT team before proceeding. (Notez qu'utiliser la méthode ci-dessous peut avoir un impact sur les autres applications qui s'exécutent également avec FlexNet. Adressez-vous à votre équipe informatique avant de continuer.)

Sur l'ordinateur exécutant Tableau Desktop, supprimez manuellement les fichiers de préférences FLEXnet du dossier Library. Pour trouver et supprimer les fichiers de préférences FlexNet, consultez les étapes ci-dessous :
  1. Fermez Tableau Desktop
  2. Ouvrez le Finder
  3. Sélectionnez Aller > Aller au dossier depuis la barre de menu en haut de l'écran
  4. Saisissez /Library/Preferences/FLEXnet Publisher/FLEXnet et sélectionnez Aller
  5. Mettez en surbrillance tous les éléments dans le répertoire et utilisez les touches CMD + SUPPR pour les supprimer
    • Remarque : les fichiers peuvent aussi être supprimés si vous sélectionnez l'option Icône d'engrenage > Déplacer vers la Corbeille pendant que les éléments sont en surbrillance
  6. Redémarrez l'ordinateur
  7. Ouvrez Tableau Desktop et entrez votre clé produit pour activer le produit si nécessaire. 

Option 3 - Pour Tableau Desktop 2019.2 et versions antérieures

Sur l'ordinateur exécutant Tableau Desktop, veuillez réinstallez manuellement le package FlexNet. Pour trouver et installer les composants de licence FlexNet, consultez les étapes ci-dessous :
  1. Dans le Finder, cliquez sur Applications.
  2. Maintenez la touche Contrôle enfoncée, cliquez sur Tableau et sélectionnez Afficher le contenu du package (Show Package Contents).
  3. Double-cliquez sur Contents (Contenu), double-cliquez sur Installers (Programmes d'installation), puis double-cliquez sur Tableau FLEXNET.pkg.
  4. Suivez les instructions de l'assistant d'installation et utilisez les options par défaut.

    • Remarque : vous pouvez être invité à saisir votre clé produit. 
  5. Une fois l'installation FLEXNet terminée, redémarrez l'ordinateur.
Ressources supplémentaires
Remarque : les fichiers tableau_xxxxxxx_event.log et tableau_xxxxxxx_tsf.data_backup répertoriés dans la sortie (après l'exécution de ls -l /Library/Preferences/FLEXnet\ Publisher/FLEXnet cmd) doivent appartenir au système local de l'utilisateur rencontrant le problème et disposer des autorisations -rw-r--r-- et -rw-rw-rw-, respectivement. S'ils appartiennent à un autre utilisateur ou possèdent des autorisations incorrectes, essayez de les modifier manuellement. 

Pour plus d'informations, reportez-vous à Erreurs : « Le service d'octroi de licences FLEXNet n'est pas présent » ou « La fonction flxActAppActivationSend a renvoyé une erreur (0,0,0) » lors de l'activation sur Mac


Numéro d’article de la base de connaissances

001473090

 
Chargement
Salesforce Help | Article