Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

エラー "ユーザー <username> はコンテンツを所有しているため削除できませんでした" がユーザーを削除しようとすると発生する

公開日: Jul 17, 2025
説明
ユーザーを削除しようとすると、ユーザーがワークブック、ビュー、データ ソースなどを所有していないと思われるにもかかわらず、次のエラー メッセージが表示される場合があります。
User <username> could not be deleted because they own content. <username> has been unlicensed. (コンテンツを所有しているため、ユーザー <username> を削除できませんでした。<username> はライセンスが解除されました。)

Cause

プロジェクトなどのコンテンツを所有するユーザーは削除できませんが、ライセンスは解除されます。詳細については、Tableau Cloud ヘルプの「サーバーからユーザーを削除」を参照してください。

サブスクリプションについては、ユーザー A がユーザー B をサブスクリプションに登録した場合、このサブスクリプションはユーザー A のコンテンツ ページに表示されません。  ユーザー A には、特定のユーザーのサブスクライブ先を表示するパーミッションがありません。
解決策

ステップ 1 - ユーザーが所有しているコンテンツを見つける

  1. 所有者のユーザー ページに移動します (所有者名を検索して、[ユーザー] で名前を選択します)。
  2. ユーザーが所有するコンテンツは、プロジェクトを含め、すべて個別のタブで表示されます。 
  3. 別のユーザーにコンテンツの所有権を変更します。

注:
必ず [サイト設定] ページで「データに聞く」のレンズとコレクションの作成を有効にしてください。無効になっていると、対応するタブが UI に表示されず、サイト管理者がこれらの内容を確認できないためです。

ステップ 2 - サブスクリプションを見つける

Tableau Server 管理者は [タスク] > [サブスクリプション] に移動して、ユーザーにまだ関連付けられているサブスクリプションを見つけることができます。  ユーザー検索では、ユーザーに関連付けられているサブスクリプションを見つけられない可能性があります。

[サブスクリプション] 列で並べ替えてから、スクロールしてユーザーを見つけます。  そのユーザーのアカウントに関連付けられた「サブスクリプション」が残っている可能性があります。 サブスクリプションがあるユーザーを書き留めて、新しいコンテンツ所有者でサブスクライブし直します。

ビューをサブスクライブしているユーザーのライセンスが解除された場合、ユーザーのサブスクリプションは残っていますがメールは送信されません。  ユーザー数が非常に多いため、ライセンスのないユーザーがサブスクリプションのみを保持している場合、このユーザーのサブスクリプションを削除することはサーバーのパフォーマンスにとって重要です。  Tableau Server は処理を行いますが、メールは送信しません。

ステップ 3: ごみ箱からコンテンツ (ワークブック、プロジェクト、データソース) を削除する

ごみ箱には、Tableau サイトのホームページからアクセスできます。サイドペインを展開し、[ごみ箱] を選択します。

  1. 右側のペインにある [ユーザー] フィルターを適用し、該当ユーザーが所有するワークブックを削除します。
  2. 右上隅にある [コンテンツの種類] フィルターを [プロジェクト] に変更し、同様の手順でユーザーが所有するプロジェクトを削除します。
  3. [コンテンツの種類] フィルターを [データソース] に変更し、同様の手順でユーザーが所有するデータソースを削除します。

これらの手順完了後、再度サイトからのユーザー削除を試みてください。

ナレッジ記事番号

001473120

 
読み込み中
Salesforce Help | Article