Loading

Errores "Setting site role for user to <role> failed", "Insufficient licenses" o "Exceeds limit for Creator role"

Fecha de publicación: Dec 19, 2023
Descripción
Al intentar agregar un nuevo usuario o asignar una función de sitio a un usuario en Tableau Server o Tableau Cloud, se podría producir uno de los siguientes errores:

Setting site role for user <username> to '<siterole>' failed (Error al establecer el rol de sitio del usuario <username> para '<siterole>').
Insufficient licenses. Setting user roles to '<siterole>' failed (Licencias insuficientes. Error al establecer las funciones de usuario para "<siterole>").
O
Exceeds limit for '<siterole>' role (Excede el límite para <siterole>).

Cause

Al intentar agregar un nuevo usuario o asignar una función en el sitio a un usuario en Tableau Server, el entorno de Tableau Server alcanza o supera el número total de puestos disponibles.

Tableau puede degradar ciertas funciones para completar la solicitud de un usuario nuevo.  Por ejemplo, podría no haber puestos de Creador disponibles porque una solicitud de Explorador nuevo asumió la función de Creador disponible.  La página de uso de licencias se vería así:

Creador 4/5 Explorador 1/0 Visualizador: 15/15
Solución

Tableau Cloud

  1. Inicie sesión en Tableau Cloud como administrador de sitio y compruebe la cantidad total de puestos disponibles para cada función de sitio en la página Usuarios (para cada tipo de función de sitio, el número a la derecha es la cantidad de licencias compradas en su sitio para esa función, y el número a la izquierda es la cantidad de usuarios que actualmente tienen asignada esa función).
  2. Si una función de sitio excede el límite, convierta los usuarios existentes a la función de sitio deseada o quite la licencia a los usuarios para liberar puestos de la función de sitio deseada.
  3. Si lo que desea es adquirir puestos adicionales por un aumento de la demanda, visite el sitio web de Tableau para comprar más licencias.



Tableau Server para Windows 2018.2 y versiones posteriores, Tableau Server para Linux 

  1. Compruebe que todas las claves de licencia se hayan activado. Para ello, vaya al Portal del cliente de Tableau y seleccione el informe "Claves: Solo Server".  Ejecute el comando TSM Licenses List para comparar las claves activadas con el informe de claves totales.  Para saber más sobre cómo añadir claves de producto, consulte Añadir capacidad a Tableau Server.
  2. Compruebe que las claves de licencia estén actualizadas con una fecha de mantenimiento activa. Para obtener más información, consulte Actualizar la fecha de mantenimiento para la clave de producto
  3. Reinicie Tableau Server utilizando los siguientes comandos para sincronizar Tableau Server con el almacenamiento de confianza.
  4. Abra el símbolo del sistema como administrador y vaya a la carpeta bin de Tableau Server, situada de forma predeterminada en el directorio C:\Program Files\Tableau\Tableau Server\packages\bin.<version> en Windows o en /opt/tableau/tableau_server/packages/bin.<version> en Linux.
tsm stop
lmreread
tsm start

En un entorno multisitio de Tableau Server: 

Si Tableau Server refleja el número correcto de licencias disponibles en un sitio, pero no puede añadir un nuevo usuario:
  1. Seleccione Administrar todos los sitios y revise la lista completa de usuarios.
  2. Confirme que el número de usuarios en Todos los sitios no supere el número de puestos de licencia. 
 

 
Recursos adicionales
Compruebe el número de puestos asignados para determinar si se superó la capacidad de la función de Explorador y, por lo tanto, está consumiendo capacidad de la función de Creador disponible.  Las licencias de creador pueden utilizarse para cumplir la función de Explorador y los puestos de Explorador pueden utilizarse para cumplir la función de Observador. No es posible utilizar puestos de creador para cumplir la función de Observador.

Consulte el blog de la comunidad de Tableau: No es posible asignar funciones en Tableau Server con las licencias disponible

 
Número del artículo de conocimiento

001473145

 
Cargando
Salesforce Help | Article