Loading

Errori "Setting site role for user to <role> failed" o "Insufficient licenses" o "Exceeds limit for Creator role"

Data pubblicazione: Dec 19, 2023
Descrizione
Quando si tenta di aggiungere un nuovo utente o di assegnare un ruolo del sito a un utente su Tableau Server o Tableau Cloud, potrebbe verificarsi uno dei seguenti messaggi di errore:

Setting site role for user <username> to '<siterole>' failed (Impossibile impostare il ruolo sito per l'utente <nome utente> su '<ruolo sito>')
Oppure 
Insufficient licenses. Setting site role for user <username> to '<siterole>' failed (Licenze insufficienti. Impossibile impostare il ruolo sito per l'utente <nome utente> su '<ruolo sito>')
o
Exceeds limit for '<siterole>' role (Supera il limite per il ruolo '<ruolo sito>')

Cause

Durante un tentativo di aggiunta di un nuovo utente o di assegnazione di un ruolo del sito a un utente su Tableau Server, l'ambiente di Tableau Server ha raggiunto o superato il numero totale di postazioni disponibili.

Tableau può retrocedere i ruoli per evadere una richiesta per un nuovo utente.  Ad esempio, potrebbero non esserci postazioni Creator disponibili perché una richiesta per un nuovo Explorer ha preso il ruolo Creator disponibile.  La pagina sull'utilizzo delle licenze avrà all'incirca questo aspetto:

Creator 4/5 Explorer 1/0 Viewer: 15/15
Risoluzione

Tableau Cloud

  1. Accedi a Tableau Cloud come Amministratore del sito e verifica il numero totale di postazioni disponibili per ciascun ruolo del sito nella pagina Utenti (per ciascun tipo di ruolo del sito, il numero a destra rappresenta il numero di licenze acquistate sul tuo sito per quel ruolo, mentre il numero a sinistra è il numero di utenti attualmente assegnati a quel ruolo).
  2. Se un determinato ruolo del sito supera il limite, converti gli utenti esistenti nel ruolo del sito desiderato o annulla la licenza per gli utenti in modo da liberare le postazioni del ruolo del sito desiderato.
  3. Se desideri acquistare ulteriori postazioni perché è aumentata la richiesta, visita il sito Web di Tableau per acquistare altre licenze.



Tableau Server su Windows 2018.2 e versioni successive, Tableau Server su Linux 

  1. Verifica che tutti i codici di licenza siano attivati visitando il Portale clienti di Tableau e selezionando il report "Codici - Solo server".  Esegui il comando tsm licenses list per confrontare i codici attivati con il report dei codici totali.  Per maggiori informazioni sull'aggiunta dei codici prodotto, consulta Aggiungere capacità a Tableau Server.
  2. Assicurati che tutti i codici di licenza siano aggiornati con una data di manutenzione attiva. Per maggiori informazioni, consulta Aggiornare la data di manutenzione del codice prodotto
  3. Riavvia Tableau Server tramite i seguenti comandi per sincronizzarlo con l'Archiviazione attendibile.
  4. Apri un prompt dei comandi come amministratore e passa alla cartella bin di Tableau Server, disponibile per impostazione predefinita in C:\Program Files\Tableau\Tableau Server\packages\bin.<versione> su Windows o /opt/tableau/tableau_server/packages/bin.<versione> su Linux.
tsm stop
lmreread
tsm start

In un ambiente multisito di Tableau Server: 

Se Tableau Server presenta il numero corretto di licenze disponibili su un singolo sito, ma non è ancora in grado di aggiungere un nuovo utente:
  1. Seleziona Gestisci tutti i siti e rivedi l'elenco completo degli utenti.
  2. Conferma che il numero di utenti su Tutti i siti non superi il numero di postazioni per licenza. 
 

 
Risorse aggiuntive
Controlla il numero di postazioni assegnate per determinare se il ruolo Explorer ha superato la capacità e sta quindi attingendo dal ruolo Creator disponibile.  Le licenze Creator possono essere utilizzate per agire come ruolo Explorer e le postazioni Explorer possono essere utilizzate per agire come ruolo Viewer. Le postazioni Creator non possono essere utilizzate per agire come ruolo Viewer.

Consulta il Blog della Community di Tableau - Unable to Assign Roles on Tableau Server with Available Licenses

 
Numero articolo Knowledge

001473145

 
Caricamento
Salesforce Help | Article