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Échec de la connexion SAML avec OKTA comme IdP

Date de publication: Jul 20, 2023
Description
Après la configuration d'OKTA SAML, les utilisateurs ne sont pas en mesure de se connecter. Les messages suivants peuvent également apparaître dans les journaux :

Caused by: org.opensaml.ws.security.SecurityPolicyException: Validation of protocol message signature failed (La validation de la signature du message de protocole a échoué)

et :

<time stamp> (,,,) catalina-exec-2 :DEBUG com.tableausoftware.domain.user.saml.SAMLExtendedProcessingFilter - SAML login failed due generic exception Incoming SAML message is invalid
<time stamp> (,,,) catalina-exec-2 : INFO  com.tableausoftware.domain.user.saml.SAMLExtendedProcessingFilter - SAML login failed, redirecting user to /#/error/signin/16?redirectPath=/wg/saml/logout/index.html

et :

<time stamp> (,,,) catalina-exec-2 : DEBUG org.springframework.security.saml.trust.MetadataCredentialResolver - Added 0 credentials resolved from metadata of entity http://www.okta.com/exk177go76l9YoHb11d8

Cause

L'URL de redirection dans les métadonnées Tableau Server actuelles est obsolète. 
Résolution
Réexportez les métadonnées depuis Okta.

 
Ressources supplémentaires
Vous pouvez tester rapidement si le problème provient bien de la redirection en tentant une connexion initiée par un fournisseur de service. Si cela entraîne une erreur 404 dans Okta, l'URL de redirection est incorrecte. 


Numéro d’article de la base de connaissances

001473149

 
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Salesforce Help | Article