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L'accesso SAML non riesce con OKTA come IdP

Data pubblicazione: Jul 20, 2023
Descrizione
Dopo aver configurato SAML di OKTA, gli utenti non sono in grado di accedere. Inoltre, nei log può essere registrato quanto segue: 

Caused by: org.opensaml.ws.security.SecurityPolicyException: Validation of protocol message signature failed

e:

<time stamp> (,,,) catalina-exec-2 : DEBUG com.tableausoftware.domain.user.saml.SAMLExtendedProcessingFilter - SAML login failed due generic exception Incoming SAML message is invalid
<time stamp> (,,,) catalina-exec-2 : INFO  com.tableausoftware.domain.user.saml.SAMLExtendedProcessingFilter - SAML login failed, redirecting user to /#/error/signin/16?redirectPath=/wg/saml/logout/index.html

e:

<time stamp> (,,,) catalina-exec-2 : DEBUG org.springframework.security.saml.trust.MetadataCredentialResolver - Added 0 credentials resolved from metadata of entity http://www.okta.com/exk177go76l9YoHb11d8

Cause

L'URL di reindirizzamento negli attuali metadati di Tableau Server è obsoleto. 
Risoluzione
Esporta nuovamente i metadati da Okta. 

 
Risorse aggiuntive
Un test rapido per determinare se è il reindirizzamento a causare il problema consiste nel provare un accesso avviato da SP. Se il risultato è un errore 404 da Okta, l'URL di reindirizzamento non è corretto. 


Numero articolo Knowledge

001473149

 
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