Loading

OKTA を IdP として使用すると SAML サインインが失敗する

公開日: Jul 20, 2023
説明
OKTA SAML を設定した後、ユーザーがログインできません。さらに、以下のログが記録されます。

Caused by: org.opensaml.ws.security.SecurityPolicyException: Validation of protocol message signature failed (原因: プロトコル メッセージの署名の検証に失敗しました)

および

<time stamp> (,,,) catalina-exec-2 : DEBUG com.tableausoftware.domain.user.saml.SAMLExtendedProcessingFilter - SAML login failed due generic exception Incoming SAML message is invalid (一般的な例外のために SAML ログインが失敗しました。着信 SAML メッセージが無効です。)
<time stamp> (,,,) catalina-exec-2 : INFO  com.tableausoftware.domain.user.saml.SAMLExtendedProcessingFilter - SAML login failed, redirecting user to /#/error/signin/16?redirectPath=/wg/saml/logout/index.html (SAML ログインに失敗し、ユーザーをリダイレクトしています。)

および

<time stamp> (,,,) catalina-exec-2 : DEBUG org.springframework.security.saml.trust.MetadataCredentialResolver - Added 0 credentials resolved from metadata of entity http://www.okta.com/exk177go76l9YoHb11d8 (エンティティのメタデータから解決された認証資格情報を 0 個追加しました。)

Cause

現在の Tableau Server メタデータのリダイレクト URL が古くなっています。
解決策
Okta からメタデータをもう一度エクスポートします。

 
その他のリソース
リダイレクトが問題であるかどうかを簡単にテストするには、SP が開始したサインインを試します。その結果 Okta から 404 が返されると、リダイレクト URL は正しくありません。


ナレッジ記事番号

001473149

 
読み込み中
Salesforce Help | Article