Loading

Error: "The field <fieldname> does not exist in the database" después de actualizar la fuente de datos para incluir un nuevo campo

Fecha de publicación: Jun 6, 2023
Descripción
Al administrar fuentes de datos por separado desde los libros de trabajo (el administrador publica una extracción, y los usuarios se conectan a la extracción publicada), los cambios en la extracción publicada a veces provocan errores de cálculo basados en el libro de trabajo. Puede darse uno de los siguientes casos: 
  • Los cálculos se vuelven de color rojo.
  • El cálculo puede mostrar 1 1 1 al final del nombre.
  • Aparece el error de cálculo "The field <fieldname> does not exist in the database" (El campo <nombre de campo> no existe en la base de datos).

Cause

Al agregar campos a una fuente de datos con Tableau Desktop, puede sobrescribirse la identificación de back-end de todos los campos. Es especialmente probable que SQL personalizado cause un cambio de nombre en los campos en el back-end.
Los libros de trabajo hacen lo posible para buscar coincidencias después del cambio de nombre, pero esto no siempre funciona.

 

Solución

Opción 1

Administre las fuentes de datos creando una vista materializada en la base de datos. (Consulte Vistas materializadas, a continuación)

Opción 2

Si no es posible crear una vista materializada, cree la fuente de datos en Tableau Desktop sin usar SQL personalizado. 
  • Solo agregue campos nuevos; no obstante, tenga en cuenta que pueden aparecer errores al quitar o modificar campos.
Recursos adicionales
El error se produce para todos los métodos de actualización de la fuente de datos, incluidos los siguientes:
  • Cuando se vuelve a publicar la fuente de datos con el mismo nombre, el usuario del libro de trabajo actualiza la conexión con la fuente de datos publicada.
  • Cuando se publica la fuente de datos con un nuevo nombre, el usuario del libro de trabajo crea una nueva conexión con la opción "Reemplazar fuente de datos".
  • Cuando se publica la fuente de datos con un nuevo nombre, el usuario del libro de trabajo utiliza las opciones "Editar servidor" y "Ruta del sitio" para apuntar a la nueva fuente de datos. 

Vistas materializadas

Una vista materializada es una "consulta seleccionada" realizada en la fuente de datos y el conjunto de resultados final se almacena en una tabla en la base de datos. La vista materializada puede guardarse en sincronización con las actualizaciones de la base de datos.
Número del artículo de conocimiento

001473192

 
Cargando
Salesforce Help | Article