Loading

Erreur "Unable to start service 'tabsrv'" lors du démarrage de Tableau Server

Date de publication: Aug 24, 2022
Description
Impossible de démarrer Tableau Server avec le message d'erreur :

com.tableausoftware.tabctl.dll.Exception: Unable to start service 'tabsvc': (1068) The dependency service or group failed to start (Échec du démarrage du service ou groupe de dépendance)

OU


com.tableausoftware.tabctl.dll.NoServiceError: No service named 'tabsvc' is installed (1060)  on worker nodes (Aucun service appelé 'tabsvc' n'est installé (1060) sur les nœuds worker)

Cause

Si vous n'êtes pas en mesure de démarrer le service, il se peut que les autorisations de l'utilisateur du compte Exécuter en tant qu'utilisateur ne soient pas valides. Si vous modifiez les autorisations sur un autre utilisateur puis à nouveau sur celui doté des droits/autorisations nécessaires, les autorisations sont réinitialisées pour les dossiers sur Tableau Server.

tabsrv peut s'afficher comme non installé lorsqu'un précédent processus de configuration a été interrompu ou n'a pas été autorisé à s'exécuter jusqu'au bout. Durant le processus d'installation, Tableau Server désinstalle et réinstalle tabsvc sur les ordinateurs worker. Si ce processus d'installation est interrompu, le service ne terminera jamais complètement le processus de réinstallation.
Résolution

Vous pouvez utiliser les options suivantes comme solution pour le problème :

Option 1

  1. Vérifiez si le « compte Exécuter en tant qu'utilisateur » est correct et inclut le nom de domaine, ou le nom de l'ordinateur s'il utilise un compte administrateur local.
  2. Exécutez « tabadmin configure » à la ligne de commande depuis le nœud Tableau Server principal.
Option 2
  1. Modifiez le nombre de processus pour l'ordinateur affecté dans les paramètres de Tableau Server (vous pouvez les remodifier une fois que vous avez terminé). Cette opération réinstalle le service tabsrv.
Numéro d’article de la base de connaissances

001473193

 
Chargement
Salesforce Help | Article