Loading

Fehler "Could Not Open a Connection" beim Aktualisieren von Extrakten in Tableau Cloud

Veröffentlichungsdatum: Nov 9, 2023
Beschreibung

Wenn Sie in Tableau Cloud eine Arbeitsmappe mit eingebetteten Datenquellen aktualisieren oder wenn Sie eine veröffentlichte Datenquelle aktualisieren, schlägt die Aktualisierung unter Umständen mit folgendem Fehler fehl:

Error: com.tableausoftware.nativeapi.dll.DataSourceException: [Microsoft][SQL Server Native Client 11.0]Named Pipes Provider: Could not open a connection to SQL Server [53] [Microsoft][SQL Server Native Client 11.0]Login timeout expired [Microsoft][SQL Server Native Client 11.0]A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. (Es konnte keine Verbindung mit SQL Server geöffnet werden[53] [Microsoft][SQL Server Native Client 11.0]Anmeldezeitüberschreitung abgelaufen [Microsoft][SQL Server Native Client 11.0]Ein netzwerkbezogener oder instanzspezifischer Fehler ist beim Herstellen einer Verbindung mit SQL Server aufgetreten. Server nicht gefunden oder nicht zugänglich.)Check if instance name is correct and if SQL Server is configured to allow remote connections. (Prüfen Sie, ob der Instanzname korrekt ist und ob SQL Server so konfiguriert ist, dass Remote-Verbindungen zulässig sind.)Weitere Informationen finden Sie in der Onlinedokumentation zu SQL Server. Unable to connect to the server "<SERVER NAME>". (Keine Verbindung mit Server "<SERVER NAME>" möglich.) Check that the server is running and that you have access privileges to the requested database. (Funktion "OCIArrayDescriptorAlloc" nicht in OCI gefunden (Fehler 127): Treiber sind u. U. veraltet. Die Verbindung zum Server "<Serveradresse>" kann nicht hergestellt werden. Stellen Sie sicher, dass der Server ausgeführt wird und dass Sie über Zugriffsberechtigungen für die angeforderte Datenbank verfügen.)

Cause

Für das Extrakt wurde festgelegt, dass die Aktualisierung über den Aktualisierungsprozess von Tableau Cloud und nicht über Tableau Bridge erfolgt. Die Tableau Cloud-Server haben keinen Zugriff auf die Quelldatenbank, um die Aktualisierung durchzuführen.
Lösung

Für Arbeitsmappen mit eingebetteten Datenquellen
  1. Veröffentlichen Sie aus der Arbeitsmappe heraus jede Datenquelle separat. Informationen finden Sie unter Veröffentlichen von Datenquellen und Arbeitsmappen.
  2. Navigieren Sie nach dem Veröffentlichen zur Inhaltsseite jeder Datenquelle in Tableau Cloud. Klicken Sie auf die Registerkarte "Aktualisierungszeitpläne".
  3. Klicken Sie rechts auf der Seite auf die Schaltfläche mit dem Text "Diesen Extrakt aktualisieren auf...".
  4. Wählen Sie "Computer in meinem Netzwerk..." und wählen Sie den Computer, auf dem Tableau Bridge installiert ist. Wenn Tableau Bridge für diese Site noch nicht eingerichtet ist, erfahren Sie unter Erweitern von Optionen zur Datenaktualität mithilfe von Tableau Bridge mehr über die ersten Schritte.
Für veröffentlichte Datenquellen
  1. Navigieren Sie in Tableau Cloud zur Inhaltsseite jeder Datenquelle. Klicken Sie auf die Registerkarte "Aktualisierungszeitpläne".
  2. Klicken Sie rechts auf der Seite auf die Schaltfläche mit dem Text "Diesen Extrakt aktualisieren auf...".
  3. Wählen Sie "Computer in meinem Netzwerk..." und wählen Sie den Computer, auf dem Tableau Bridge installiert ist. Wenn Tableau Bridge für diese Site noch nicht eingerichtet ist, erfahren Sie unter Erweitern von Optionen zur Datenaktualität mithilfe von Tableau Bridge mehr über die ersten Schritte.
Zusätzliche Ressourcen


Über diesen Artikel diskutieren... Feedback-Forum
Nummer des Knowledge-Artikels

001473194

 
Laden
Salesforce Help | Article