Loading

Erreur "Could Not Open a Connection" lors de l'actualisation d'un extrait sur Tableau Cloud

Date de publication: Nov 9, 2023
Description

Dans Tableau Cloud, lors de l'actualisation d'un classeur avec des sources de données intégrées ou de l'actualisation d'une source de données publiée, l'actualisation peut échouer avec l'erreur suivante :

Error: com.tableausoftware.nativeapi.dll.DataSourceException: [Microsoft][SQL Server Native Client 11.0]Named Pipes Provider: Could not open a connection to SQL Server [53] [Microsoft][SQL Server Native Client 11.0]Login timeout expired [Microsoft][SQL Server Native Client 11.0]A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online. Unable to connect to the server "<SERVER NAME>". Check that the server is running and that you have access privileges to the requested database. (Fournisseur de canaux nommés : Impossible d'ouvrir une connexion à SQL Server [53] [Microsoft][SQL Server Native Client 11.0]Expiration du délai de connexion [Microsoft][SQL Server Native Client 11.0] Une erreur liée au réseau ou spécifique à l'instance s'est produite lors de l'établissement d'une connexion à SQL Server. Le serveur est introuvable ou inaccessible. Vérifiez si le nom de l'instance est correct et si SQL Server est configuré pour autoriser les connexions distantes. Pour plus d'informations, consultez SQL Server Books Online. Impossible de se connecter au serveur « <adresse serveur> ». Vérifiez que le serveur est en cours d'exécution et que vous disposez de privilèges d'accès à la base de données demandée.)

Cause

L'actualisation de l'extrait a été configurée à l'aide des processus d'actualisation Tableau Cloud plutôt que Tableau Bridge. Les serveurs Tableau Cloud n'ont pas accès à la base de données source pour effectuer l'actualisation.
Résolution

Pour les classeurs avec sources de données intégrées
  1. Publiez chaque source de données indépendamment du classeur.Consultez Publier des sources de données et des classeurs.
  2. Après la publication, accédez à la page de contenu de chaque source de données sur Tableau Cloud. Cliquez sur l'onglet Programmation d'actualisation.
  3. Sur le côté droit de la page, cliquez sur le bouton étiqueté « Actualiser cet extrait sur… ».
  4. Choisissez « Un ordinateur de mon réseau… » et sélectionnez l'ordinateur sur lequel Tableau Bridge est installé. Si Tableau Bridge n'a pas encore été configuré pour ce site, consultez Utiliser Tableau Bridge pour développer les options d'actualisation des données pour démarrer.
Pour les sources de données publiées
  1. Accédez à la page de contenu de chaque source de données sur Tableau Cloud. Cliquez sur l'onglet Programmation d'actualisation.
  2. Sur le côté droit de la page, cliquez sur le bouton étiqueté « Actualiser cet extrait sur… ».
  3. Choisissez « Un ordinateur de mon réseau… » et sélectionnez l'ordinateur sur lequel Tableau Bridge est installé. Si Tableau Bridge n'a pas encore été configuré pour ce site, consultez Utiliser Tableau Bridge pour développer les options d'actualisation des données pour démarrer.
Ressources supplémentaires


Discuter de cet article... Forum de commentaires
Numéro d’article de la base de connaissances

001473194

 
Chargement
Salesforce Help | Article