Loading

Errore "Could Not Open a Connection" durante l'aggiornamento dell'estrazione su Tableau Cloud

Data pubblicazione: Nov 9, 2023
Descrizione

In Tableau Cloud, quando si aggiorna una cartella di lavoro con origini dati incorporate o un'origine dati pubblicata, l'aggiornamento potrebbe non riuscire con il seguente errore:

Error: com.tableausoftware.nativeapi.dll.DataSourceException: [Microsoft][SQL Server Native Client 11.0]Named Pipes Provider:Could not open a connection to SQL Server [53] [Microsoft][SQL Server Native Client 11.0]Login timeout expired [Microsoft][SQL Server Native Client 11.0]A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online. Unable to connect to the server "<SERVER NAME>". Check that the server is running and that you have access privileges to the requested database. (Errore: com.tableausoftware.nativeapi.dll.DataSourceException: [Microsoft][SQL Server Native Client 11.0]Provider named pipe: impossibile aprire una connessione a SQL Server [53] [Microsoft][SQL Server Native Client 11.0]Timeout di accesso scaduto [Microsoft][SQL Server Native Client 11.0]Si è verificato un errore relativo alla rete o specifico dell'istanza durante la creazione di una connessione a SQL Server. Il server non è stato trovato o non è accessibile. Verifica che il nome dell'istanza sia corretto e che SQL Server sia configurato per consentire le connessioni remote. Per ulteriori informazioni, consulta SQL Server Books Online. Impossibile connettersi al server "<NOME SERVER>". Verifica che il server sia in esecuzione e di disporre dei privilegi di accesso al database richiesto.)

Cause

L'estrazione è stata impostata per l'aggiornamento tramite i processi di aggiornamento di Tableau Cloud anziché Tableau Bridge. I server Tableau Cloud non hanno accesso al database di origine per eseguire l'aggiornamento.
Risoluzione

Per cartelle di lavoro con origini dati incorporate
  1. Pubblica ogni origine dati separatamente dalla cartella di lavoro. Consulta Pubblicare origini dati e cartelle di lavoro.
  2. Dopo la pubblicazione, vai alla pagina dei contenuti per ciascuna origine dati su Tableau Cloud. Fai clic sulla scheda Pianifica aggiornamenti.
  3. Sul lato destro della pagina, fai clic sul pulsante "Aggiorna questa estrazione in...".
  4. Scegli "Un computer sulla mia rete..." e seleziona il computer in cui è installato Tableau Bridge. Se Tableau Bridge non è stato ancora configurato per il sito, consulta Espandere le opzioni di aggiornamento dei dati usando Tableau Bridge per iniziare.
Per le origini dati pubblicate
  1. Vai alla pagina dei contenuti per ciascuna origine dati su Tableau Cloud. Fai clic sulla scheda Pianifica aggiornamenti.
  2. Sul lato destro della pagina, fai clic sul pulsante "Aggiorna questa estrazione in...".
  3. Scegli "Un computer sulla mia rete..." e seleziona il computer in cui è installato Tableau Bridge. Se Tableau Bridge non è stato ancora configurato per il sito, consulta Espandere le opzioni di aggiornamento dei dati usando Tableau Bridge per iniziare.
Risorse aggiuntive


Commenta questo articolo... Feedback Forum
Numero articolo Knowledge

001473194

 
Caricamento
Salesforce Help | Article