Loading

Erreur "(50003, 71000,19002) LM_TS_OPEN_ERROR Tableau could not access Trusted Storage." lors de l'ouverture de Tableau sur un Mac

Date de publication: Jul 20, 2023
Description
Lors de l'ouverture de Tableau Desktop sur un Mac, l'erreur suivante peut se produire :
Function flxActCommonHandleOpen returned error (50003, 71000,19002) LM_TS_OPEN_ERROR Tableau could not access Trusted Storage (Tableau n'a pas pu accéder à Trusted Storage)

Cause

Tableau doit être autorisé à écrire sur le dossier Temporary (/TMP) pour résoudre le problème.
Résolution

Option 1 : Activer les autorisations Exécuter sur le dossier private/tmp. 

  1. Fermez Tableau Desktop.
  2. Pour vérifier les autorisations sur le dossier private/tmp, ouvrez le Terminal puis exécutez les commandes suivantes dans l'ordre :
    cd /
    cd /private
    ls -l
    Si la première colonne de texte affiche drwrwrw, le dossier tmp ne dispose pas des autorisations Exécuter dont FlexNet a besoin pour activer Tableau Desktop avec succès.
  3. Assurez-vous que l'utilisateur root est activé. Pour plus d'informations, consultez Activation et utilisation de l'utilisateur root dans OS X dans la base de connaissances d'Apple.

  4. Définissez les autorisations du dossier private/tmp sur Exécuter. Dans le Terminal, tapez chacune des commandes suivantes dans l'ordre, en appuyant sur Entrée après chaque commande :
    sudo -s pwd <root_password> 
    whoami
    chmod 1777 tmp
    ls -l
    La première colonne affiche désormais drwxrwxrwt ou drwxrwxrwx.
  5. Ouvrez Tableau Desktop et tentez une nouvelle activation.
Pour plus d'information, consultez Comprendre les autorisations UNIX et chmod sur Perlfect.com


Option 2 : Corriger les autorisations du dossier Temporary (/TMP) selon les besoins. 

Si ce message d'erreur s'affiche également lors de la tentative de création d'un fichier dans le dossier Temporary (/TMP) de l'ordinateur : 'a file operation for coretelephony tracing has failed'. Suivez les étapes décrites dans ce Billet de la communauté Apple

Option 3 : Mettre à niveau le système d'exploitation

Si le système d'exploitation n'est pas à jour, veuillez mettez à niveau au système d'exploitation le plus récent pour Sierra Mac.
Ressources supplémentaires

Numéro d’article de la base de connaissances

001473314

 
Chargement
Salesforce Help | Article