Loading

Errore "(50003, 71000,19002) LM_TS_OPEN_ERROR Tableau could not access Trusted Storage." durante l'apertura di Tableau su un Mac

Data pubblicazione: Jul 20, 2023
Descrizione
Aprendo Tableau Desktop su un Mac, potrebbe verificarsi il seguente errore:
Function flxActCommonHandleOpen returned error (50003, 71000,19002) LM_TS_OPEN_ERROR Tableau could not access Trusted Storage. (La funzione flxActCommonHandleOpen ha restituito un errore (50003, 71000,19002) LM_TS_OPEN_ERROR - Tableau non ha potuto accedere all'archiviazione attendibile.)

Cause

Per risolvere il problema, Tableau deve disporre delle autorizzazioni per la scrittura nella cartella temporanea (/TMP).
Risoluzione

Opzione 1: Abilita le autorizzazioni di esecuzione per la cartella private/tmp.

  1. Chiudi Tableau Desktop.
  2. Per verificare le autorizzazioni per la cartella private/tmp, apri Terminale ed esegui questi comandi nell'ordine specificato:
    cd /
    cd /private
    ls -l
    Se nella prima colonna del testo visualizzato è indicato drwrwrw, la cartella tmp non dispone delle autorizzazioni di esecuzione richieste da FlexNet per attivare correttamente Tableau Desktop.
  3. Assicurati che l'utente root sia abilitato. Per maggiori informazioni, consulta Enabling and using the root user in OS X nella Knowledge Base di Apple.

  4. Imposta le autorizzazioni di esecuzione per la cartella private/tmp. In Terminale, digita ciascuno dei seguenti comandi nell'ordine specificato, premendo Invio dopo ogni comando: 
    sudo -s pwd <root_password> 
    whoami
    chmod 1777 tmp
    ls -l
    La prima colonna ora dovrebbe mostrare drwxrwxrwt o drwxrwxrwx.
  5. Apri Tableau Desktop e riprova a eseguire l'attivazione.
Per ulteriori informazioni, consulta Understanding UNIX permissions and chmod sul sito Perlfect.com


Opzione 2: Correggi le autorizzazioni della cartella temporanea (/TMP) in base alle esigenze. 

Se viene visualizzato anche questo messaggio di errore durante il tentativo di creare un file nella cartella temporanea (/TMP) del computer: "a file operation for coretelephony tracing has failed" (operazione su un file per la traccia coretelephony non riuscita), Segui i passaggi descritti in questo post della Community di Apple

Opzione 3: Esegui l'upgrade del sistema operativo

Se il sistema operativo non è aggiornato, esegui l'upgrade al sistema operativo più recente per Sierra Mac.
Risorse aggiuntive

Numero articolo Knowledge

001473314

 
Caricamento
Salesforce Help | Article