Loading

Error "Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'"

Fecha de publicación: Jul 20, 2023
Descripción
Tras actualizar el controlador SQL a ODBC 13, puede que Tableau Desktop lance el siguiente error:

[Microsoft][ODBC Driver 13 for SQL Server][SQL Server]Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'." on a live connection. ([Microsoft][ODBC Driver 13 for SQL Server][SQL Server] No se pudo iniciar sesión con el usuario 'NT AUTHORITY\ANONYMOUS LOGON' en una conexión activa).

Cause

El mensaje de error "NT AUTHORITY\ANONYMOUS LOGON" indica un error de delegación de Kerberos. El artículo, Métodos de autenticación para conexiones al servidor SQL en páginas de servidor activo, del soporte técnico de Microsoft Support aporta más información sobre el tema.

Solución

Opción 1

Hable con el equipo interno de IT para abordar el problema de delegación de Kerberos. Los artículos de información adicional del soporte técnico de Microsoft pueden servirle de ayuda.

Opción 2

Desinstale el controlador ODBC 13 para SQL Server e instale SQL Native Client:
  1. Diríjase a Añadir/Eliminar programas
  2. Borre el controlador ODBC 13 de Microsoft para SQL Server
  3. Descargue SQL Native Client para SQL Server
  4. Instale el controlador cliente nativo sqlncli.msi
Recursos adicionales

Como describe la documentación de Microsoft, el cliente nativo y el controlador ODBC tratan la delegación de manera ligeramente diferente. Esto es debido a que el problema normalmente aparece después de actualizar el controlador de SQL Server y porque revertir el controlador a una versión anterior puede solucionar el problema. También es importante saber que al conectarse a SQL Server con Windows Auth, si Kerberos no funciona, la conexión pasa a usar NTLM en su lugar. Sin embargo, cualquier delegación o conexión de doble salto necesita Kerberos.


Métodos de autenticación para conexiones a SQL Server en Active Server Pages del soporte técnico de Microsoft.
Cómo habilitar el registro de eventos de Kerberos del soporte técnico de Microsoft.

Nota: la publicación de blog anterior se encuentra en un sitio web de terceros. Aunque hacemos todo lo posible para que las referencias al contenido de terceros sean precisas, la información proporcionada aquí podría cambiar sin previo aviso.
 


Número del artículo de conocimiento

001473408

 
Cargando
Salesforce Help | Article