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Error "SSL_connect: certificate verify failed" conectándose a Cloudera Hadoop

Fecha de publicación: Jul 20, 2023
Descripción
Al conectarse a un subárbol Cloudera Hadoop Hive o servidor Impala desde Tableau Desktop, puede producirse uno de los siguientes errores.
[Cloudera][ImpalaODBC] (100) Error from the Impala Thrift API:SSL_connect: certificate verify failed ([Cloudera][ImpalaODBC] (100) Error de la API Impala Thrift: Error de verificación del certificado SSL_connect.)
o
[Cloudera][Hardy] (34) Error from server ([Cloudera][Hardy] (34) Error del servidor): SSL_connect: certificate verify failed (Error al verificar el certificado SSL_connect).

O al conectarse desde Tableau Server, puede producirse este error:
Unable to connect to the data source.
Try connecting again. If the problem persists, disconnect from the data source and contact the data source owner (No es posible conectarse a la fuente de datos. Vuelva a intentar conectarse. Si el problema persiste, desconéctese de la fuente de datos y contacte con su propietario).
Unable to connect to the ODBC Data Source. Check that the necessary drivers are installed and that the connection proprties are valid. (No se ha podido conectar con la fuente de datos ODBC. Compruebe que se han instalado los controladores necesarios y que las propiedades de la conexión son válidas.
[Cloudera][ImpalaODBC] (100) Error de la API Impala Thrift: SSL_CTX_load_verify_locations: error code (SSL_CTX_load_verify_locations: código de error): 0
Unable to connect to the server <name>.Check that the server is running and that you have access privileges to the requested database. (No se ha podido conectar con el servidor <name>. Compruebe que el servidor está en ejecución y que dispone de privilegios de acceso a la base de datos solicitada).

Cause

Tableau Desktop oTableau Server no puede localizar el certificado SSL.
Solución
Hable con su equipo local de TI o intente alguna de las opciones siguientes. 

Opción 1:

Instale el certificado SSL Impala en la raíz de certificados con el gestor de certificados de Windows (certmgr.msc) o a través de la política de grupo.

Opción 2:

  1. Guarde una copia del certificado .pem del servidor Impala al equipo que tiene Tableau Desktop. 
  2. Descargue y edite el archivo TDC para especificar la ruta de archivo para los certificados de confianza (no es necesario ponerlo entre comillas), y después añada el archivo .tdc a:
    1. (Tableau Desktop):La carpeta My Tableau Repository\Datasources.
    2. (Tableau Server para Windows): En el directorio de datos Tableau Server, en tabsvc\vizqlserver\Datasources. La ruta predeterminada es C:\ProgramData\Tableau\Tableau Server\data\tabsvc\vizqlserver\Datasources
    3. (Tableau Server para Linux): En el directorio de datos Tableau Server, en tabsvc/vizqlserver/Datasources. La ruta predeterminada es /var/opt/tableau/tableau_server/data/tabsvc/vizqlserver/Datasources/

Opción 3:

Sobrescriba el archivo cacerts.pem que se instaló con los controladores ODBC con el certificado autofirmado creado por el servidor de la base de datos.Ejemplos de posibles ubicaciones del archivo:
C:\Program Files (x86)\Cloudera ODBC Driver for Impala\lib
C:\Program Files\Cloudera ODBC Driver for Apache Hive\lib
Recursos adicionales
Para hacer cualquier cambio en Tableau Server, estos se deben aplicar a todos los nodos que usen procesos que deriven en conexiones a la fuente de datos (procesador de segundo plano, servidor de datos, Vizportal, servidor VizQL).
Al usar la opción 2 en Tableau Server, el archivo TDC debe coincidir exactamente con su homólogo en Tableau Desktop: la misma letra de unidad, ruta de archivo y nombre que el archivo .PEM.
 

Número del artículo de conocimiento

001473448

Archivos adjuntos

hadoopssl2.tdc

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